aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Gorski <jonas.gorski@gmail.com>2018-09-10 11:42:53 +0200
committerJo-Philipp Wich <jo@mein.io>2019-01-22 13:22:49 +0100
commit99e5ba3207280efbf79868c5b0507c8b637bc1e2 (patch)
tree672190eb9f4370832b9d58efa7512e2e25ae6d0f
parent0c8e8e2dc9ac10b077d814ce1ad84a8a4174fee1 (diff)
downloadupstream-99e5ba3207280efbf79868c5b0507c8b637bc1e2.tar.gz
upstream-99e5ba3207280efbf79868c5b0507c8b637bc1e2.tar.bz2
upstream-99e5ba3207280efbf79868c5b0507c8b637bc1e2.zip
opkg: drop argument from check_signature in opkg.conf
check_signature is a bool option and doesn't take any arguments. The presence of the 1 falsely suggests setting it to 0 disables the check, while the option actually needs to be removed or commented out to be disabled. So remove the argument to make it more clear. Fixes: beca028bd6bb ("build: add integration for managing opkg package feed keys") Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com> (backported from commit d3bf5ff9bc7b55b2a3dab93853b33a0cd2c4ca47)
-rw-r--r--package/system/opkg/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/system/opkg/Makefile b/package/system/opkg/Makefile
index 876a72d016..5e57c2f0ed 100644
--- a/package/system/opkg/Makefile
+++ b/package/system/opkg/Makefile
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/version.mk
include $(INCLUDE_DIR)/feeds.mk
PKG_NAME:=opkg
-PKG_RELEASE:=1
+PKG_RELEASE:=1.1
PKG_FLAGS:=essential
PKG_SOURCE_PROTO:=git
@@ -91,7 +91,7 @@ define Package/opkg/install
$(INSTALL_BIN) ./files/20_migrate-feeds $(1)/etc/uci-defaults/
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/opkg-cl $(1)/bin/opkg
ifneq ($(CONFIG_SIGNED_PACKAGES),)
- echo "option check_signature 1" >> $(1)/etc/opkg.conf
+ echo "option check_signature" >> $(1)/etc/opkg.conf
endif
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) ./files/opkg-key $(1)/usr/sbin/