aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2010-04-26 18:27:51 +0000
committerGabor Juhos <juhosg@openwrt.org>2010-04-26 18:27:51 +0000
commit8470d973ee4369dc20a7e19ad55b049070a5767a (patch)
tree2049ba55d7670397eb8b24b134665db6ecb9740a
parent97b031b57fd28e154628f5a0031d85975853d637 (diff)
downloadupstream-8470d973ee4369dc20a7e19ad55b049070a5767a.tar.gz
upstream-8470d973ee4369dc20a7e19ad55b049070a5767a.tar.bz2
upstream-8470d973ee4369dc20a7e19ad55b049070a5767a.zip
ar71xx: create firmware images for the TL-WR941ND v3 boards
SVN-Revision: 21169
-rw-r--r--target/linux/ar71xx/image/Makefile5
-rw-r--r--target/linux/ar71xx/profiles/tp-link.mk11
2 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index a5f02703c9..dfcc5f6f08 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -518,6 +518,10 @@ define Image/Build/Profile/TLWR941NDV2
$(call Image/Build/Template/$(fs_squash)/$(1),TPLINK,tl-wr941nd-v2,board=TL-WR941ND,TL-WR941NDv2)
endef
+define Image/Build/Profile/TLWR941NDV3
+ $(call Image/Build/Template/$(fs_squash)/$(1),TPLINK,tl-wr941nd-v3,board=TL-WR941ND,TL-WR941NDv2)
+endef
+
define Image/Build/Profile/TLWR941NDV4
$(call Image/Build/Template/$(fs_4k)/$(1),TPLINK,tl-wr941nd-v4,board=TL-WR741ND,TL-WR941NDv4)
endef
@@ -566,6 +570,7 @@ define Image/Build/Profile/Default
$(call Image/Build/Profile/TLWR841NDV3,$(1))
$(call Image/Build/Profile/TLWR841NDV5,$(1))
$(call Image/Build/Profile/TLWR941NDV2,$(1))
+ $(call Image/Build/Profile/TLWR941NDV3,$(1))
$(call Image/Build/Profile/TLWR941NDV4,$(1))
$(call Image/Build/Profile/TLWR1043NDV1,$(1))
$(call Image/Build/Profile/UBNT,$(1))
diff --git a/target/linux/ar71xx/profiles/tp-link.mk b/target/linux/ar71xx/profiles/tp-link.mk
index ffb3b9e06d..7efb1a3766 100644
--- a/target/linux/ar71xx/profiles/tp-link.mk
+++ b/target/linux/ar71xx/profiles/tp-link.mk
@@ -60,6 +60,17 @@ endef
$(eval $(call Profile,TLWR941NDV2))
+define Profile/TLWR941NDV3
+ NAME:=TP-LINK TL-WR941ND v3
+ PACKAGES:=kmod-ath9k wpad-mini
+endef
+
+define Profile/TLWR941NDV3/Description
+ Package set optimized for the TP-LINK TL-WR941ND v3.
+endef
+
+$(eval $(call Profile,TLWR941NDV3))
+
define Profile/TLWR941NDV4
NAME:=TP-LINK TL-WR941ND v4
PACKAGES:=kmod-ath9k wpad-mini