aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2010-04-26 18:28:10 +0000
committerGabor Juhos <juhosg@openwrt.org>2010-04-26 18:28:10 +0000
commit497d2ec2d00fb8490dcbb46733615d29e0a920f8 (patch)
tree33ec60d2d1c31541e9e5125d4dcac1b3b7088755
parentedac7e5a63a717ae8c2fbe29a8a1a29c61a55d78 (diff)
downloadupstream-497d2ec2d00fb8490dcbb46733615d29e0a920f8.tar.gz
upstream-497d2ec2d00fb8490dcbb46733615d29e0a920f8.tar.bz2
upstream-497d2ec2d00fb8490dcbb46733615d29e0a920f8.zip
ar71xx: create separate 'factory' and 'sysupgrade' images for the Planex boards
SVN-Revision: 21175
-rw-r--r--target/linux/ar71xx/image/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 42d67ca838..c6721de48e 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -294,13 +294,13 @@ define Image/Build/Planex
-d $(KDIR)/vmlinux-$(2).bin.gz $(KDIR)/vmlinux-$(2).uImage; \
( \
dd if=$(KDIR)/vmlinux-$(2).uImage bs=1408k conv=sync; \
- dd if=$(KDIR)/root.$(1) bs=6208k conv=sync; \
- ) > $(call imgname,$(1),$(2)).bin; \
+ dd if=$(KDIR)/root.$(1); \
+ ) > $(call imgname,$(1),$(2))-sysupgrade.bin; \
$(STAGING_DIR_HOST)/bin/mkplanexfw \
-B $(2) \
-v 2.00.00 \
- -i $(call imgname,$(1),$(2)).bin \
- -o $(call imgname,$(1),$(2)).webui; \
+ -i $(call imgname,$(1),$(2))-sysupgrade.bin \
+ -o $(call imgname,$(1),$(2))-factory.bin; \
fi; fi
endef