aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGad Krumholz <gad.krumholz@gmail.com>2016-11-27 00:52:53 -0600
committerGad Krumholz <gad.krumholz@gmail.com>2016-11-30 00:47:10 -0600
commitd9740d24d767d583da08eeaa8bd7a01288fdc554 (patch)
tree5fda396bbe79871356ce3d25e2ed83ebcd3a0bfe
parent1b6dc2e48ce654a004a7d0b98d7070a515424595 (diff)
downloadupstream-d9740d24d767d583da08eeaa8bd7a01288fdc554.tar.gz
upstream-d9740d24d767d583da08eeaa8bd7a01288fdc554.tar.bz2
upstream-d9740d24d767d583da08eeaa8bd7a01288fdc554.zip
CC: ar71xx: Added missing support for Linksys E2100L
It's based on the WRT160NL according to https://wiki.openwrt.org/toh/linksys/e2100l Based on research done here: https://forum.openwrt.org/viewtopic.php?id=24244 and here: https://forum.openwrt.org/viewtopic.php?pid=120791#p120791 this patch was conceived. Signed-off-by: Gad Krumholz <gad.krumholz@gmail.com>
-rw-r--r--target/linux/ar71xx/base-files/etc/diag.sh3
-rwxr-xr-xtarget/linux/ar71xx/base-files/lib/ar71xx.sh3
-rwxr-xr-xtarget/linux/ar71xx/base-files/lib/upgrade/platform.sh1
-rw-r--r--target/linux/ar71xx/config-3.181
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/mach-e2100l.c126
-rw-r--r--target/linux/ar71xx/generic/profiles/linksys.mk10
-rw-r--r--target/linux/ar71xx/image/Makefile2
-rw-r--r--target/linux/ar71xx/patches-3.18/610-MIPS-ath79-openwrt-machines.patch19
-rw-r--r--tools/firmware-utils/src/addpattern.c7
9 files changed, 169 insertions, 3 deletions
diff --git a/target/linux/ar71xx/base-files/etc/diag.sh b/target/linux/ar71xx/base-files/etc/diag.sh
index 486879f512..623e2a43b5 100644
--- a/target/linux/ar71xx/base-files/etc/diag.sh
+++ b/target/linux/ar71xx/base-files/etc/diag.sh
@@ -358,6 +358,9 @@ get_status_led() {
wrt400n)
status_led="wrt400n:blue:wps"
;;
+ e2100l)
+ status_led="e2100l:blue:wps"
+ ;;
wrt160nl)
status_led="wrt160nl:blue:wps"
;;
diff --git a/target/linux/ar71xx/base-files/lib/ar71xx.sh b/target/linux/ar71xx/base-files/lib/ar71xx.sh
index a9dca58847..1eb6999908 100755
--- a/target/linux/ar71xx/base-files/lib/ar71xx.sh
+++ b/target/linux/ar71xx/base-files/lib/ar71xx.sh
@@ -932,6 +932,9 @@ ar71xx_board_detect() {
*WRT160NL)
name="wrt160nl"
;;
+ *E2100L)
+ name="e2100l"
+ ;;
*WRT400N)
name="wrt400n"
;;
diff --git a/target/linux/ar71xx/base-files/lib/upgrade/platform.sh b/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
index 762cd760ce..fda7bc417c 100755
--- a/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
@@ -270,6 +270,7 @@ platform_check_image() {
;;
mynet-rext|\
+ e2100l|\
wrt160nl)
cybertan_check_image "$1" && return 0
return 1
diff --git a/target/linux/ar71xx/config-3.18 b/target/linux/ar71xx/config-3.18
index e0d52d9fcb..22faed440e 100644
--- a/target/linux/ar71xx/config-3.18
+++ b/target/linux/ar71xx/config-3.18
@@ -159,6 +159,7 @@ CONFIG_ATH79_MACH_WPJ344=y
CONFIG_ATH79_MACH_WPJ531=y
CONFIG_ATH79_MACH_WPJ558=y
CONFIG_ATH79_MACH_WRT160NL=y
+CONFIG_ATH79_MACH_E2100L=y
CONFIG_ATH79_MACH_WRT400N=y
CONFIG_ATH79_MACH_WZR_450HP2=y
CONFIG_ATH79_MACH_WZR_HP_AG300H=y
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-e2100l.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-e2100l.c
new file mode 100644
index 0000000000..c09083460e
--- /dev/null
+++ b/target/linux/ar71xx/files/arch/mips/ath79/mach-e2100l.c
@@ -0,0 +1,126 @@
+/*
+ * Linksys E2100L board support
+ *
+ * Copyright (C) 2009-2012 Gabor Juhos <juhosg@openwrt.org>
+ *
+ * This program is free software; you can redistribute it and/or modify it
+ * under the terms of the GNU General Public License version 2 as published
+ * by the Free Software Foundation.
+ */
+
+#include <asm/mach-ath79/ath79.h>
+
+#include "dev-eth.h"
+#include "dev-gpio-buttons.h"
+#include "dev-leds-gpio.h"
+#include "dev-m25p80.h"
+#include "dev-usb.h"
+#include "dev-wmac.h"
+#include "nvram.h"
+#include "machtypes.h"
+
+#define E2100L_GPIO_LED_POWER 14
+#define E2100L_GPIO_LED_WPS_AMBER 9
+#define E2100L_GPIO_LED_WPS_BLUE 8
+#define E2100L_GPIO_LED_WLAN 6
+
+#define E2100L_GPIO_BTN_WPS 7
+#define E2100L_GPIO_BTN_RESET 21
+
+#define E2100L_KEYS_POLL_INTERVAL 20 /* msecs */
+#define E2100L_KEYS_DEBOUNCE_INTERVAL (3 * E2100L_KEYS_POLL_INTERVAL)
+
+#define E2100L_NVRAM_ADDR 0x1f7e0000
+#define E2100L_NVRAM_SIZE 0x10000
+
+static const char *e2100l_part_probes[] = {
+ "cybertan",
+ NULL,
+};
+
+static struct flash_platform_data e2100l_flash_data = {
+ .part_probes = e2100l_part_probes,
+};
+
+static struct gpio_led e2100l_leds_gpio[] __initdata = {
+ {
+ .name = "e2100l:blue:power",
+ .gpio = E2100L_GPIO_LED_POWER,
+ .active_low = 1,
+ .default_trigger = "default-on",
+ }, {
+ .name = "e2100l:amber:wps",
+ .gpio = E2100L_GPIO_LED_WPS_AMBER,
+ .active_low = 1,
+ }, {
+ .name = "e2100l:blue:wps",
+ .gpio = E2100L_GPIO_LED_WPS_BLUE,
+ .active_low = 1,
+ }, {
+ .name = "e2100l:blue:wlan",
+ .gpio = E2100L_GPIO_LED_WLAN,
+ .active_low = 1,
+ }
+};
+
+static struct gpio_keys_button e2100l_gpio_keys[] __initdata = {
+ {
+ .desc = "reset",
+ .type = EV_KEY,
+ .code = KEY_RESTART,
+ .debounce_interval = E2100L_KEYS_DEBOUNCE_INTERVAL,
+ .gpio = E2100L_GPIO_BTN_RESET,
+ .active_low = 1,
+ }, {
+ .desc = "wps",
+ .type = EV_KEY,
+ .code = KEY_WPS_BUTTON,
+ .debounce_interval = E2100L_KEYS_DEBOUNCE_INTERVAL,
+ .gpio = E2100L_GPIO_BTN_WPS,
+ .active_low = 1,
+ }
+};
+
+static void __init e2100l_setup(void)
+{
+ const char *nvram = (char *) KSEG1ADDR(E2100L_NVRAM_ADDR);
+ u8 *eeprom = (u8 *) KSEG1ADDR(0x1fff1000);
+ u8 mac[6];
+
+ if (ath79_nvram_parse_mac_addr(nvram, E2100L_NVRAM_SIZE,
+ "lan_hwaddr=", mac) == 0) {
+ ath79_init_mac(ath79_eth0_data.mac_addr, mac, 0);
+ ath79_init_mac(ath79_eth1_data.mac_addr, mac, 1);
+ }
+
+ ath79_register_mdio(0, 0x0);
+
+ ath79_eth0_data.phy_if_mode = PHY_INTERFACE_MODE_RMII;
+ ath79_eth0_data.phy_mask = 0x01;
+
+ ath79_eth1_data.phy_if_mode = PHY_INTERFACE_MODE_RMII;
+ ath79_eth1_data.phy_mask = 0x10;
+
+ ath79_register_eth(0);
+ ath79_register_eth(1);
+
+ ath79_register_m25p80(&e2100l_flash_data);
+
+ ath79_register_usb();
+
+ if (ath79_nvram_parse_mac_addr(nvram, E2100L_NVRAM_SIZE,
+ "wl0_hwaddr=", mac) == 0)
+ ath79_register_wmac(eeprom, mac);
+ else
+ ath79_register_wmac(eeprom, NULL);
+
+ ath79_register_leds_gpio(-1, ARRAY_SIZE(e2100l_leds_gpio),
+ e2100l_leds_gpio);
+
+ ath79_register_gpio_keys_polled(-1, E2100L_KEYS_POLL_INTERVAL,
+ ARRAY_SIZE(e2100l_gpio_keys),
+ e2100l_gpio_keys);
+}
+
+MIPS_MACHINE(ATH79_MACH_E2100L, "E2100L", "Linksys E2100L",
+ e2100l_setup);
diff --git a/target/linux/ar71xx/generic/profiles/linksys.mk b/target/linux/ar71xx/generic/profiles/linksys.mk
index bedf3a3d49..973eb6e24a 100644
--- a/target/linux/ar71xx/generic/profiles/linksys.mk
+++ b/target/linux/ar71xx/generic/profiles/linksys.mk
@@ -14,6 +14,15 @@ define Profile/WRT160NL/Description
Package set optimized for the Linksys WRT160NL.
endef
+define Profile/E2100L
+ NAME:=Linksys E2100L
+ PACKAGES:=kmod-usb-core kmod-usb2
+endef
+
+define Profile/E2100L/Description
+ Package set optimized for the Linksys E2100L
+endef
+
define Profile/WRT400N
NAME:=Linksys WRT400N
PACKAGES:=
@@ -24,4 +33,5 @@ define Profile/WRT400N/Description
endef
$(eval $(call Profile,WRT160NL))
+$(eval $(call Profile,E2100L))
$(eval $(call Profile,WRT400N))
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index a8073f2eca..6cbaf380d9 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -1981,6 +1981,8 @@ $(eval $(call SingleProfile,CameoDB120_8M,64kraw,TEW732BR,tew-732br,TEW-732BR,tt
$(eval $(call SingleProfile,CyberTANGZIP,64k,WRT160NL,wrt160nl,WRT160NL,ttyS0,115200,,1.00.01))
+$(eval $(call SingleProfile,CyberTANGZIP,64k,E2100L,e2100l,E2100L,ttyS0,115200,,1.00.01))
+
$(eval $(call SingleProfile,CyberTANLZMA,64k,MYNETREXT,mynet-rext,MYNET-REXT,ttyS0,115200,$$(mynet_rext_mtdlayout) root=31:2,1.00.01))
$(eval $(call SingleProfile,CameoAP94,64kraw,DIR825B1,dir-825-b1,DIR-825-B1,ttyS0,115200,$$(cameo_ap94_mtdlayout),$$(cameo_ap94_mtdlayout_fat),01AP94-AR7161-RT-080619-00,00AP94-AR7161-RT-080619-00))
diff --git a/target/linux/ar71xx/patches-3.18/610-MIPS-ath79-openwrt-machines.patch b/target/linux/ar71xx/patches-3.18/610-MIPS-ath79-openwrt-machines.patch
index 76aeb94412..ae8d9ffb12 100644
--- a/target/linux/ar71xx/patches-3.18/610-MIPS-ath79-openwrt-machines.patch
+++ b/target/linux/ar71xx/patches-3.18/610-MIPS-ath79-openwrt-machines.patch
@@ -1,6 +1,6 @@
--- a/arch/mips/ath79/machtypes.h
+++ b/arch/mips/ath79/machtypes.h
-@@ -16,22 +16,200 @@
+@@ -16,22 +16,201 @@
enum ath79_mach_type {
ATH79_MACH_GENERIC = 0,
@@ -190,6 +190,7 @@
+ ATH79_MACH_WPJ531, /* Compex WPJ531 */
+ ATH79_MACH_WPJ558, /* Compex WPJ558 */
+ ATH79_MACH_WRT160NL, /* Linksys WRT160NL */
++ ATH79_MACH_E2100L, /* Linksys E2100L */
+ ATH79_MACH_WRT400N, /* Linksys WRT400N */
+ ATH79_MACH_WZR_HP_AG300H, /* Buffalo WZR-HP-AG300H */
+ ATH79_MACH_WZR_HP_G300NH, /* Buffalo WZR-HP-G300NH */
@@ -283,7 +284,7 @@
config ATH79_MACH_AP121
bool "Atheros AP121 reference board"
select SOC_AR933X
-@@ -11,62 +84,1050 @@ config ATH79_MACH_AP121
+@@ -11,62 +84,1061 @@ config ATH79_MACH_AP121
select ATH79_DEV_M25P80
select ATH79_DEV_USB
select ATH79_DEV_WMAC
@@ -774,6 +775,17 @@
+ select ATH79_DEV_WMAC
+ select ATH79_NVRAM
+
++config ATH79_MACH_E2100L
++ bool "Linksys E2100L board support"
++ select SOC_AR913X
++ select ATH79_DEV_ETH
++ select ATH79_DEV_GPIO_BUTTONS
++ select ATH79_DEV_LEDS_GPIO
++ select ATH79_DEV_M25P80
++ select ATH79_DEV_USB
++ select ATH79_DEV_WMAC
++ select ATH79_NVRAM
++
+config ATH79_MACH_WRT400N
+ bool "Linksys WRT400N board support"
+ select SOC_AR71XX
@@ -1495,7 +1507,7 @@
endif
--- a/arch/mips/ath79/Makefile
+++ b/arch/mips/ath79/Makefile
-@@ -38,9 +38,128 @@ obj-$(CONFIG_ATH79_ROUTERBOOT) += route
+@@ -38,9 +38,129 @@ obj-$(CONFIG_ATH79_ROUTERBOOT) += route
#
# Machines
#
@@ -1615,6 +1627,7 @@
+obj-$(CONFIG_ATH79_MACH_WPJ531) += mach-wpj531.o
+obj-$(CONFIG_ATH79_MACH_WPJ558) += mach-wpj558.o
+obj-$(CONFIG_ATH79_MACH_WRT160NL) += mach-wrt160nl.o
++obj-$(CONFIG_ATH79_MACH_E2100L) += mach-e2100l.o
+obj-$(CONFIG_ATH79_MACH_WRT400N) += mach-wrt400n.o
+obj-$(CONFIG_ATH79_MACH_WZR_HP_G300NH) += mach-wzr-hp-g300nh.o
+obj-$(CONFIG_ATH79_MACH_WZR_HP_G300NH2) += mach-wzr-hp-g300nh2.o
diff --git a/tools/firmware-utils/src/addpattern.c b/tools/firmware-utils/src/addpattern.c
index 1d72285610..29ec99396a 100644
--- a/tools/firmware-utils/src/addpattern.c
+++ b/tools/firmware-utils/src/addpattern.c
@@ -113,6 +113,13 @@ struct board_info boards[] = {
.flags = {0x3f, 0x00},
},
{
+ .id = "E2100L",
+ .pattern = "NL1X",
+ .hw_ver = 0x00,
+ .sn = 0x0f,
+ .flags = {0x3f, 0x00},
+ },
+ {
.id = "mynet-rext",
.pattern = "WDHNSTFH",
.hw_ver = 0x00,