aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-08-10 18:35:29 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-08-10 18:35:29 +0000
commitd3c8499987750194e7b986e2bb7b10a0c967763e (patch)
tree0417d4e642cc98f4b90bddaeac9554d5822042ec
parent855c45a8b9e6e11d6c0a3e074c26f121f633e278 (diff)
downloadupstream-d3c8499987750194e7b986e2bb7b10a0c967763e.tar.gz
upstream-d3c8499987750194e7b986e2bb7b10a0c967763e.tar.bz2
upstream-d3c8499987750194e7b986e2bb7b10a0c967763e.zip
x86: Fix CONFIG_X86_GRUB_SERIAL=""
With .config:CONFIG_X86_GRUB_SERIAL="" which (AFAICT) is the way to tell GRUB not to use a serial console, in target/linux/x86/image/Makefile:ifneq ($(CONFIG_X86_GRUB_SERIAL),) $(CONFIG_X86_GRUB_SERIAL) expands to `""' (a literal double double-quote), making the condition unconditionally false. This patch fixes the situation by passing CONFIG_X86_GRUB_SERIAL through qstrip before testing. Signed-off-by: Tamas TEVESZ <ice@extreme.hu> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37749 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--target/linux/x86/image/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/target/linux/x86/image/Makefile b/target/linux/x86/image/Makefile
index 039d70ab82..d3ada9fad2 100644
--- a/target/linux/x86/image/Makefile
+++ b/target/linux/x86/image/Makefile
@@ -28,8 +28,10 @@ ifneq ($(CONFIG_X86_GRUB_CONSOLE),)
GRUB_TERMINALS += console
endif
-ifneq ($(CONFIG_X86_GRUB_SERIAL),)
- GRUB_CONSOLE_CMDLINE += console=$(call qstrip,$(CONFIG_X86_GRUB_SERIAL)),$(CONFIG_X86_GRUB_BAUDRATE)n8
+GRUB_SERIAL:=$(call qstrip,$(CONFIG_X86_GRUB_SERIAL))
+
+ifneq ($(GRUB_SERIAL),)
+ GRUB_CONSOLE_CMDLINE += console=$(GRUB_SERIAL),$(CONFIG_X86_GRUB_BAUDRATE)n8
GRUB_SERIAL_CONFIG := serial --unit=0 --speed=$(CONFIG_X86_GRUB_BAUDRATE) --word=8 --parity=no --stop=1
GRUB_TERMINALS += serial
endif