aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-04-06 19:26:30 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-04-06 19:26:30 +0000
commitd1212499c8924d637b86f8559de72cd7c2d02590 (patch)
tree1470d7678650a79685e1af5b1f860e9c7d631d60
parent899dbbd6149b8b3e9a732ba1cf1835db8605f50c (diff)
downloadupstream-d1212499c8924d637b86f8559de72cd7c2d02590.tar.gz
upstream-d1212499c8924d637b86f8559de72cd7c2d02590.tar.bz2
upstream-d1212499c8924d637b86f8559de72cd7c2d02590.zip
ar71xx: fix new mktplinkfw image code - flags for sysupgrade vs factory were swapped (fixes #19400)
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45281 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--target/linux/ar71xx/image/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 9459683afb..8766756871 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -57,8 +57,8 @@ define Build/mktplinkfw
-r $@ \
-o $@.new \
-a $(call rootfs_align,$(FILESYSTEM)) \
- $(if $(findstring sysupgrade,$1),-j -X 0x40000) \
- $(if $(findstring factory,$1),-j -X 0x40000 -s) \
+ $(if $(findstring sysupgrade,$1),-j -X 0x40000 -s) \
+ $(if $(findstring factory,$1),-j -X 0x40000) \
$(if $(findstring initramfs,$1),-s -c)
@mv $@.new $@
endef