aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2009-01-04 12:56:31 +0000
committerFlorian Fainelli <florian@openwrt.org>2009-01-04 12:56:31 +0000
commitcf59f8469a4531b462b4c2a3f37bbf0fea65bfb8 (patch)
treef94b3a880c2ca6daea197fd8012c68a08460c4b8
parent97005e1e041bfe0d30948bb430e5e308073a8d8a (diff)
downloadupstream-cf59f8469a4531b462b4c2a3f37bbf0fea65bfb8.tar.gz
upstream-cf59f8469a4531b462b4c2a3f37bbf0fea65bfb8.tar.bz2
upstream-cf59f8469a4531b462b4c2a3f37bbf0fea65bfb8.zip
Fix ssp enabling/disabling (#4388)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@13856 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--toolchain/gcc/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/toolchain/gcc/Makefile b/toolchain/gcc/Makefile
index f11bd8c30b..9b3a34a0b5 100644
--- a/toolchain/gcc/Makefile
+++ b/toolchain/gcc/Makefile
@@ -52,9 +52,9 @@ SEP:=,
TARGET_LANGUAGES:="c$(if $(CONFIG_INSTALL_LIBSTDCPP),$(SEP)c++)$(if $(CONFIG_INSTALL_LIBGCJ),$(SEP)java)"
ifeq ($(CONFIG_SSP_SUPPORT),y)
- SSP:=--enable-ssp
+ SSP:=--enable-libssp
else
- SSP:=--disable-ssp
+ SSP:=--disable-libssp
endif
EXTRA_TARGET=$(if $(CONFIG_EXTRA_TARGET_ARCH),--enable-biarch --enable-targets=$(call qstrip,$(CONFIG_EXTRA_TARGET_ARCH_NAME))-linux-uclibc)