aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-05-10 11:47:02 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-05-10 11:47:02 +0000
commitc6c8c1b3576f09708151b67d228fe20c77a4a1e3 (patch)
tree0ed7b973f21cb43f4fa35af8ee88b55858a03e0f
parent2fb73fa3e40221354e6d3c80878d06fb2bc98164 (diff)
downloadupstream-c6c8c1b3576f09708151b67d228fe20c77a4a1e3.tar.gz
upstream-c6c8c1b3576f09708151b67d228fe20c77a4a1e3.tar.bz2
upstream-c6c8c1b3576f09708151b67d228fe20c77a4a1e3.zip
ipq806x: add support for zImage kernel
This change enable zImage+appended dtb support in ipq806x kernel options. The zImage will now be generated as part of the kernel binaries. Platforms which do not have DT support enabled in U-boot can now make use of it by generating zImage files and appending dtb to it. It is not used yet but it is done as a stepping stone for early IPQ806x platforms, which did not include DT support in U-boot. Signed-off-by: Mathieu Olivari <mathieu@codeaurora.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45662 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--target/linux/ipq806x/Makefile2
-rw-r--r--target/linux/ipq806x/config-3.183
-rw-r--r--target/linux/ipq806x/config-4.03
3 files changed, 5 insertions, 3 deletions
diff --git a/target/linux/ipq806x/Makefile b/target/linux/ipq806x/Makefile
index 1512b30c03..f97db74fc3 100644
--- a/target/linux/ipq806x/Makefile
+++ b/target/linux/ipq806x/Makefile
@@ -11,7 +11,7 @@ MAINTAINER:=John Crispin <blogic@openwrt.org>
KERNEL_PATCHVER:=3.18
-KERNELNAME:=Image dtbs
+KERNELNAME:=zImage Image dtbs
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += \
diff --git a/target/linux/ipq806x/config-3.18 b/target/linux/ipq806x/config-3.18
index 8de4cb4b09..48a737452f 100644
--- a/target/linux/ipq806x/config-3.18
+++ b/target/linux/ipq806x/config-3.18
@@ -33,8 +33,10 @@ CONFIG_ARCH_WANT_IPC_PARSE_VERSION=y
CONFIG_ARCH_WANT_OPTIONAL_GPIOLIB=y
CONFIG_ARM=y
CONFIG_ARM_AMBA=y
+CONFIG_ARM_APPENDED_DTB=y
CONFIG_ARM_ARCH_TIMER=y
CONFIG_ARM_ARCH_TIMER_EVTSTREAM=y
+# CONFIG_ARM_ATAG_DTB_COMPAT is not set
CONFIG_ARM_CPU_SUSPEND=y
CONFIG_ARM_GIC=y
CONFIG_ARM_HAS_SG_CHAIN=y
@@ -48,7 +50,6 @@ CONFIG_ARM_THUMB=y
CONFIG_ARM_UNWIND=y
CONFIG_ARM_VIRT_EXT=y
CONFIG_AT803X_PHY=y
-CONFIG_AUTO_ZRELADDR=y
# CONFIG_BOOTPARAM_SOFTLOCKUP_PANIC is not set
CONFIG_BOOTPARAM_SOFTLOCKUP_PANIC_VALUE=0
CONFIG_BOUNCE=y
diff --git a/target/linux/ipq806x/config-4.0 b/target/linux/ipq806x/config-4.0
index c7bbcd9fed..9d8ff658e4 100644
--- a/target/linux/ipq806x/config-4.0
+++ b/target/linux/ipq806x/config-4.0
@@ -34,8 +34,10 @@ CONFIG_ARCH_WANT_IPC_PARSE_VERSION=y
CONFIG_ARCH_WANT_OPTIONAL_GPIOLIB=y
CONFIG_ARM=y
CONFIG_ARM_AMBA=y
+CONFIG_ARM_APPENDED_DTB=y
CONFIG_ARM_ARCH_TIMER=y
CONFIG_ARM_ARCH_TIMER_EVTSTREAM=y
+# CONFIG_ARM_ATAG_DTB_COMPAT is not set
CONFIG_ARM_CPU_SUSPEND=y
CONFIG_ARM_GIC=y
CONFIG_ARM_HAS_SG_CHAIN=y
@@ -50,7 +52,6 @@ CONFIG_ARM_THUMB=y
CONFIG_ARM_UNWIND=y
CONFIG_ARM_VIRT_EXT=y
CONFIG_AT803X_PHY=y
-CONFIG_AUTO_ZRELADDR=y
# CONFIG_BATTERY_GAUGE_LTC2941 is not set
# CONFIG_BOOTPARAM_SOFTLOCKUP_PANIC is not set
CONFIG_BOOTPARAM_SOFTLOCKUP_PANIC_VALUE=0