aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafał Miłecki <zajec5@gmail.com>2016-03-11 08:54:19 +0000
committerRafał Miłecki <zajec5@gmail.com>2016-03-11 08:54:19 +0000
commitb81b7e5f28cb71553e5f030eedc71f8446cd58b8 (patch)
treeeb58cbbf4f53485563c9f90d8f11cbeedbe469a0
parent3ed976b84669e275cf71d9861ed5c11136079382 (diff)
downloadupstream-b81b7e5f28cb71553e5f030eedc71f8446cd58b8.tar.gz
upstream-b81b7e5f28cb71553e5f030eedc71f8446cd58b8.tar.bz2
upstream-b81b7e5f28cb71553e5f030eedc71f8446cd58b8.zip
brcm47xx: image: move disabled devices to the new building system
This only drops WGR614 V9 which has 2 MiB flash and it's unlikely to get any interest. Signed-off-by: Rafał Miłecki <zajec5@gmail.com> Backport of r48975 git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@49003 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--target/linux/brcm47xx/image/Makefile16
1 files changed, 3 insertions, 13 deletions
diff --git a/target/linux/brcm47xx/image/Makefile b/target/linux/brcm47xx/image/Makefile
index 29cc50f58c..c603396d0d 100644
--- a/target/linux/brcm47xx/image/Makefile
+++ b/target/linux/brcm47xx/image/Makefile
@@ -34,15 +34,6 @@ endif
$(call prepare_generic_squashfs,$(KDIR)/fs_mark)
endef
-# $(1): filesystem type.
-# $(2): device model (used for output file).
-# $(3): board_id (device specific magic).
-# $(4): region.
-# $(5): simplified filesystem type (without block size).
-define Image/Build/Chk
- $(STAGING_DIR_HOST)/bin/mkchkimg -o $(BIN_DIR)/$(IMG_PREFIX)-$(2)-$(5).chk -k $(BIN_DIR)/$(IMG_PREFIX)-$(1).trx -b $(3) -r $(4)
-endef
-
define trxalign/jffs2-128k
-a 0x20000 -f $(KDIR)/root.$(1)
endef
@@ -364,6 +355,7 @@ ifeq ($(SUBTARGET),mips74k)
$(eval $(call NetgearDevice,wndr3400-v2,U12H187T00_NETGEAR,2))
$(eval $(call NetgearDevice,wndr3400-v3,U12H208T00_NETGEAR,1))
$(eval $(call NetgearDevice,wndr3700-v3,U12H194T00_NETGEAR,2))
+# $(eval $(call NetgearDevice,wndr3400-vcna,U12H155T01_NETGEAR,2))
$(eval $(call NetgearDevice,wndr4000,U12H181T00_NETGEAR,2))
$(eval $(call NetgearDevice,wnr1000-v3,U12H139T00_NETGEAR,2))
$(eval $(call NetgearDevice,wnr2000v2,U12H114T00_NETGEAR,2))
@@ -371,7 +363,9 @@ ifeq ($(SUBTARGET),mips74k)
$(eval $(call NetgearDevice,wnr3500l-v1-north-america,U12H136T99_NETGEAR,2))
$(eval $(call NetgearDevice,wnr3500l-v1-other-regions,U12H136T99_NETGEAR,1))
$(eval $(call NetgearDevice,wnr3500l-v2,U12H172T00_NETGEAR,1))
+# $(eval $(call NetgearDevice,wnr3500u,U12H136T00_NETGEAR,2))
$(eval $(call NetgearDevice,wnr3500-v2,U12H127T00_NETGEAR,2))
+# $(eval $(call NetgearDevice,wnr3500-v2-vc,U12H127T70_NETGEAR,2))
endif
#################################################
@@ -394,10 +388,6 @@ define Image/Build
$(STAGING_DIR_HOST)/bin/trx -o $(BIN_DIR)/$(IMG_PREFIX)-$(1)-gz.trx \
-f $(KDIR)/vmlinux.gz \
$(call trxalign/$(1),$(1))
-# $(call Image/Build/Chk,$(1),wgr614_v9,U12H094T00_NETGEAR,2,$(patsubst jffs2-%,jffs2,$(1)))
-# $(call Image/Build/Chk,$(1),wndr3400_vcna,U12H155T01_NETGEAR,2,$(patsubst jffs2-%,jffs2,$(1)))
-# $(call Image/Build/Chk,$(1),wnr3500U,U12H136T00_NETGEAR,2,$(patsubst jffs2-%,jffs2,$(1)))
-# $(call Image/Build/Chk,$(1),wnr3500v2_VC,U12H127T70_NETGEAR,2,$(patsubst jffs2-%,jffs2,$(1)))
ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
$(call Image/Build/Initramfs)
endif