aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-05-08 20:44:47 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-05-08 20:44:47 +0000
commitb37453690950609c1cc3edfb24523884aec4b361 (patch)
treedfa64d822c3bdc767752938b7ceef1a8027ac199
parentf3068cb1e34047e1e7ff7074e10bc88f0e3d075f (diff)
downloadupstream-b37453690950609c1cc3edfb24523884aec4b361.tar.gz
upstream-b37453690950609c1cc3edfb24523884aec4b361.tar.bz2
upstream-b37453690950609c1cc3edfb24523884aec4b361.zip
clean up / fix various Host/Clean templates in tools/
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15714 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--tools/autoconf/Makefile2
-rw-r--r--tools/automake/Makefile3
-rw-r--r--tools/bison/Makefile3
-rw-r--r--tools/ccache/Makefile1
-rw-r--r--tools/m4/Makefile3
-rw-r--r--tools/pkg-config/Makefile3
6 files changed, 5 insertions, 10 deletions
diff --git a/tools/autoconf/Makefile b/tools/autoconf/Makefile
index 12bbaba255..c6279494e9 100644
--- a/tools/autoconf/Makefile
+++ b/tools/autoconf/Makefile
@@ -30,7 +30,7 @@ define Host/Install
endef
define Host/Clean
- export SHELL="$(BASH)"; $(MAKE) -C $(HOST_BUILD_DIR) uninstall
+ -export SHELL="$(BASH)"; $(MAKE) -C $(HOST_BUILD_DIR) uninstall
$(call Host/Clean/Default)
endef
diff --git a/tools/automake/Makefile b/tools/automake/Makefile
index 679a954218..cd258479df 100644
--- a/tools/automake/Makefile
+++ b/tools/automake/Makefile
@@ -33,8 +33,7 @@ define Host/Install
endef
define Host/Clean
- $(MAKE) -C $(HOST_BUILD_DIR) uninstall
- $(MAKE) -C $(HOST_BUILD_DIR) clean
+ -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
$(call Host/Clean/Default)
endef
diff --git a/tools/bison/Makefile b/tools/bison/Makefile
index 58a5603ef4..60b4946820 100644
--- a/tools/bison/Makefile
+++ b/tools/bison/Makefile
@@ -25,8 +25,7 @@ define Host/Install
endef
define Host/Clean
- $(MAKE) -C $(HOST_BUILD_DIR) uninstall
- $(MAKE) -C $(HOST_BUILD_DIR) clean
+ -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
$(call Host/Clean/Default)
endef
diff --git a/tools/ccache/Makefile b/tools/ccache/Makefile
index 64108d72f9..f19c9337fb 100644
--- a/tools/ccache/Makefile
+++ b/tools/ccache/Makefile
@@ -28,7 +28,6 @@ ifneq ($(strip $(shell which ccache >/dev/null && echo found)),found)
define Host/Clean
-$(MAKE) -C $(HOST_BUILD_DIR) uninstall
- -$(MAKE) -C $(HOST_BUILD_DIR) clean
$(call Host/Clean/Default)
endef
else
diff --git a/tools/m4/Makefile b/tools/m4/Makefile
index 20b86ff040..e5e6d32665 100644
--- a/tools/m4/Makefile
+++ b/tools/m4/Makefile
@@ -25,8 +25,7 @@ define Host/Install
endef
define Host/Clean
- $(MAKE) -C $(HOST_BUILD_DIR) uninstall
- $(MAKE) -C $(HOST_BUILD_DIR) clean
+ -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
$(call Host/Clean/Default)
endef
diff --git a/tools/pkg-config/Makefile b/tools/pkg-config/Makefile
index 0a68e742a5..b4a2d5d557 100644
--- a/tools/pkg-config/Makefile
+++ b/tools/pkg-config/Makefile
@@ -27,8 +27,7 @@ define Host/Install
endef
define Host/Clean
- $(MAKE) -C $(HOST_BUILD_DIR) uninstall
- $(MAKE) -C $(HOST_BUILD_DIR) clean
+ -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
$(call Host/Clean/Default)
endef