aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-07-25 10:16:56 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-07-25 10:16:56 +0000
commitac81fe6a6642b9e413f5339cac99a4e65ba4149a (patch)
tree574f2ebe74cb50ff8609eb6e91dbbd2874e8d822
parent2eeb51ab4a025eebd3f5ba61892a8b0f5e1386bf (diff)
downloadupstream-ac81fe6a6642b9e413f5339cac99a4e65ba4149a.tar.gz
upstream-ac81fe6a6642b9e413f5339cac99a4e65ba4149a.tar.bz2
upstream-ac81fe6a6642b9e413f5339cac99a4e65ba4149a.zip
fix base-files-arch package
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1558 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--target/linux/package/openwrt/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/target/linux/package/openwrt/Makefile b/target/linux/package/openwrt/Makefile
index 75053b1485..2f90631a06 100644
--- a/target/linux/package/openwrt/Makefile
+++ b/target/linux/package/openwrt/Makefile
@@ -4,7 +4,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME := base-files-arch
PKG_RELEASE := 1
-PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)-$(BOARD)
+PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
include $(TOPDIR)/package/rules.mk
@@ -35,13 +35,15 @@ $(IDIR_OPENWRT):
$(SCRIPT_DIR)/make-ipkg-dir.sh $(IDIR_OPENWRT) ipkg/base-files-arch.control $(PKG_RELEASE) $(ARCH)
$(SED) s,base-files-arch,base-files-$(BOARD),g $(IDIR_OPENWRT)/CONTROL/control
-$(IPKG_OPENWRT):
+$(IPKG_OPENWRT): $(IDIR_OPENWRT)
mkdir -p $(IDIR_OPENWRT)/etc
cp files/network.overrides.$(BOARD) $(IDIR_OPENWRT)/etc/network.overrides
$(RSTRIP) $(IDIR_OPENWRT)
$(IPKG_BUILD) $(IDIR_OPENWRT) $(PACKAGE_DIR)
-compile: install-dev
+install: $(IPKG_OPENWRT)
+ $(IPKG) install $(IPKG_OPENWRT)
+compile: install-dev $(IPKG_OPENWRT)
install-dev:
mkdir -p $(STAGING_DIR)/usr/include
cp -a ./include/* $(STAGING_DIR)/usr/include/