aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafał Miłecki <zajec5@gmail.com>2016-03-11 08:54:06 +0000
committerRafał Miłecki <zajec5@gmail.com>2016-03-11 08:54:06 +0000
commita4d609186629db92b01433fcb751f2bc13fb0b5e (patch)
tree573a165370461bff5a67a7aafe22d4116644b8d2
parent0683576eac9a7d579be694d9318001245679fe0d (diff)
downloadupstream-a4d609186629db92b01433fcb751f2bc13fb0b5e.tar.gz
upstream-a4d609186629db92b01433fcb751f2bc13fb0b5e.tar.bz2
upstream-a4d609186629db92b01433fcb751f2bc13fb0b5e.zip
brcm47xx: image: switch Motorola devices to the new building system
Signed-off-by: Rafał Miłecki <zajec5@gmail.com> Backport of r48971 git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@48999 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--target/linux/brcm47xx/image/Makefile29
1 files changed, 22 insertions, 7 deletions
diff --git a/target/linux/brcm47xx/image/Makefile b/target/linux/brcm47xx/image/Makefile
index 1051acf256..55676f5834 100644
--- a/target/linux/brcm47xx/image/Makefile
+++ b/target/linux/brcm47xx/image/Makefile
@@ -54,10 +54,6 @@ define Image/Build/CyberTANHead
$(STAGING_DIR_HOST)/bin/addpattern -5 -p $(3) -v v$(4) -i /dev/null -o $(KDIR)/$(IMG_PREFIX)-$(2)-header.bin $(if $(6),-s $(6))
endef
-define Image/Build/Motorola
- $(STAGING_DIR_HOST)/bin/motorola-bin -$(3) $(BIN_DIR)/$(IMG_PREFIX)-$(1).trx $(BIN_DIR)/$(IMG_PREFIX)-$(2)-$(4).bin
-endef
-
define Image/Build/USR
$(STAGING_DIR_HOST)/bin/trx2usr $(BIN_DIR)/$(IMG_PREFIX)-$(1).trx $(BIN_DIR)/$(IMG_PREFIX)-$(2)-$(3).bin
endef
@@ -121,6 +117,11 @@ define Build/linksys-bin
mv $@.new $@
endef
+define Build/motorola-bin
+ $(STAGING_DIR_HOST)/bin/motorola-bin -$(MOTOROLA_DEVICE) $@ $@.new
+ mv $@.new $@
+endef
+
define Build/netgear-chk
$(STAGING_DIR_HOST)/bin/mkchkimg \
-o $@.new \
@@ -141,6 +142,7 @@ endef
DEVICE_VARS += PRODUCTID
DEVICE_VARS += DEVICE_ID VERSION
DEVICE_VARS += BOARD_ID REGION
+DEVICE_VARS += MOTOROLA_DEVICE
DEVICE_VARS += BIN_TAIL
define Device/Default
@@ -179,6 +181,19 @@ define LinksysDevice
TARGET_DEVICES += linksys-$(1)
endef
+define Device/motorola
+ IMAGES := bin
+ IMAGE/bin := trx-with-loader | motorola-bin
+endef
+
+define MotorolaDevice
+ define Device/motorola-$(1)
+ $$(Device/motorola)
+ MOTOROLA_DEVICE := $(2)
+ endef
+ TARGET_DEVICES += motorola-$(1)
+endef
+
define Device/netgear
IMAGES := chk
IMAGE/chk := trx-with-loader | netgear-chk
@@ -223,9 +238,6 @@ endef
define Image/Build/legacy/devices-with-64k-blocks
$(call Image/Build/Edi,$(1),ps1208mfg,$(patsubst jffs2-%,jffs2,$(1)))
$(call Image/Build/Huawei,$(1),e970,$(1))
- $(call Image/Build/Motorola,$(1),wa840g,2,$(patsubst jffs2-%,jffs2,$(1)))
- $(call Image/Build/Motorola,$(1),we800g,3,$(patsubst jffs2-%,jffs2,$(1)))
- $(call Image/Build/Motorola,$(1),wr850g,1,$(1))
$(call Image/Build/USR,$(1),usr5461,$(1))
endef
@@ -287,6 +299,9 @@ ifeq ($(SUBTARGET),legacy)
$(eval $(call LinksysDevice,wrt150n,N150,1.51.3))
$(eval $(call LinksysDevice,wrt160n-v1,N150,1.50.1))
$(eval $(call LinksysDevice,wrt300n-v1,EWCB,1.03.6))
+ $(eval $(call MotorolaDevice,wa840g,2))
+ $(eval $(call MotorolaDevice,we800g,3))
+ $(eval $(call MotorolaDevice,wr850g,1))
$(eval $(call NetgearDevice,wgr614-v8,U12H072T00_NETGEAR,2))
$(eval $(call NetgearDevice,wndr3300-v1,U12H093T00_NETGEAR,2))
$(eval $(call NetgearDevice,wnr834b-v2,U12H081T00_NETGEAR,2))