aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2006-01-31 11:07:21 +0000
committerImre Kaloz <kaloz@openwrt.org>2006-01-31 11:07:21 +0000
commit9a26b4651816439ad29b3df1caf69ac74f17530e (patch)
treecf6d96b7fcd8cee3ce21bd26f330d79dd8a45d5f
parentf0657ba0c28e55a02f19aff050c24de4826cde70 (diff)
downloadupstream-9a26b4651816439ad29b3df1caf69ac74f17530e.tar.gz
upstream-9a26b4651816439ad29b3df1caf69ac74f17530e.tar.bz2
upstream-9a26b4651816439ad29b3df1caf69ac74f17530e.zip
add pciutils v2.2.1
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@3077 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/Config.in1
-rw-r--r--package/pciutils/Config.in7
-rw-r--r--package/pciutils/Makefile35
-rw-r--r--package/pciutils/ipkg/pciutils.control4
4 files changed, 47 insertions, 0 deletions
diff --git a/package/Config.in b/package/Config.in
index 54fc4b794d..f10bca13bb 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -256,6 +256,7 @@ source "package/bc/Config.in"
source "package/gdbserver/Config.in"
source "package/pcmcia-cs/Config.in" # pcmcia-utils
source "package/usbutils/Config.in" # lsusb
+source "package/pciutils/Config.in"
source "package/strace/Config.in"
source "package/udev/Config.in"
source "package/watchdog/Config.in"
diff --git a/package/pciutils/Config.in b/package/pciutils/Config.in
new file mode 100644
index 0000000000..e76962f822
--- /dev/null
+++ b/package/pciutils/Config.in
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_PCIUTILS
+ prompt "pciutils.......................... Linux PCI Utilities"
+ tristate
+ default m if CONFIG_DEVEL
+ help
+ This package contains various utilities for inspecting and setting of
+ devices connected to the PCI bus.
diff --git a/package/pciutils/Makefile b/package/pciutils/Makefile
new file mode 100644
index 0000000000..6318344560
--- /dev/null
+++ b/package/pciutils/Makefile
@@ -0,0 +1,35 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=pciutils
+PKG_VERSION:=2.2.1
+PKG_RELEASE:=1
+PKG_MD5SUM:=c18e2a5f04e9abae5a42439de294f086
+
+PKG_SOURCE_URL:=ftp://atrey.karlin.mff.cuni.cz/pub/linux/pci
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,PCIUTILS,pciutils,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+ touch $@
+
+$(PKG_BUILD_DIR)/.built:
+ $(MAKE) -C $(PKG_BUILD_DIR) \
+ CC=$(TARGET_CC) CFLAGS="$(TARGET_CFLAGS)" IDSDIR="/usr/share" HOST=$(GNU_TARGET_NAME)
+ touch $@
+
+$(IPKG_PCIUTILS):
+ install -d -m0755 $(IDIR_PCIUTILS)/usr/sbin
+ install -d -m0755 $(IDIR_PCIUTILS)/usr/share
+ cp -fpR $(PKG_BUILD_DIR)/{lspci,setpci} $(IDIR_PCIUTILS)/usr/sbin/
+ cp -fpR $(PKG_BUILD_DIR)/pci.ids $(IDIR_PCIUTILS)/usr/share/
+ $(RSTRIP) $(IDIR_PCIUTILS)/
+ $(IPKG_BUILD) $(IDIR_PCIUTILS) $(PACKAGE_DIR)
diff --git a/package/pciutils/ipkg/pciutils.control b/package/pciutils/ipkg/pciutils.control
new file mode 100644
index 0000000000..b3f0c4eead
--- /dev/null
+++ b/package/pciutils/ipkg/pciutils.control
@@ -0,0 +1,4 @@
+Package: pciutils
+Priority: optional
+Section: sys
+Description: Linux PCI Utilities