aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-04-12 21:21:18 +0000
committerJohn Crispin <blogic@openwrt.org>2014-04-12 21:21:18 +0000
commit90def7f33265dc1b4f7917a0244500b17ceb5b02 (patch)
tree67ecd5acb3950e0cd009cd1664a9caf9edab0aef
parent9c2f5aeffa9ad2ac4d7313cda94ac03ccf607c47 (diff)
downloadupstream-90def7f33265dc1b4f7917a0244500b17ceb5b02.tar.gz
upstream-90def7f33265dc1b4f7917a0244500b17ceb5b02.tar.bz2
upstream-90def7f33265dc1b4f7917a0244500b17ceb5b02.zip
uboot-lantiq: add packages for Lantiq EASY50712
Signed-off-by: Daniel Schwierzeck <daniel.schwierzeck@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@40483 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/boot/uboot-lantiq/Makefile20
1 files changed, 19 insertions, 1 deletions
diff --git a/package/boot/uboot-lantiq/Makefile b/package/boot/uboot-lantiq/Makefile
index 9bf6c01f47..de83f003b0 100644
--- a/package/boot/uboot-lantiq/Makefile
+++ b/package/boot/uboot-lantiq/Makefile
@@ -63,10 +63,28 @@ define uboot/gigasx76x_nor
SOC:=danube
endef
+define uboot/easy50712_ram
+ TITLE:=U-Boot for Lantiq EASY50712 (RAM)
+ SOC:=danube
+ DDR_SETTINGS:=board/lantiq/easy50712/ddr_settings.h
+endef
+
+define uboot/easy50712_nor
+ TITLE:=U-Boot for Lantiq EASY50712 (NOR)
+ SOC:=danube
+endef
+
+define uboot/easy50712_norspl
+ TITLE:=U-Boot for Lantiq EASY50712 (NOR SPL)
+ SOC:=danube
+ IMAGE:=u-boot.ltq.lzo.norspl
+endef
+
UBOOTS:= \
arv4519pw_ram arv4519pw_nor \
arv7518pw_ram arv7518pw_nor \
- gigasx76x_ram gigasx76x_nor
+ gigasx76x_ram gigasx76x_nor \
+ easy50712_ram easy50712_nor easy50712_norspl
define Package/uboot/template
define Package/uboot-lantiq-$(1)