aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2016-04-25 20:08:44 +0000
committerJohn Crispin <blogic@openwrt.org>2016-04-25 20:08:44 +0000
commit9098797092f663002173287fdafefbd7480aeb87 (patch)
treef7846093e99f472b555c9949bee65fe9e95b7d8b
parentd7d1413f24982a75bcf2637f6441b8d6f963cf40 (diff)
downloadupstream-9098797092f663002173287fdafefbd7480aeb87.tar.gz
upstream-9098797092f663002173287fdafefbd7480aeb87.tar.bz2
upstream-9098797092f663002173287fdafefbd7480aeb87.zip
ar71xx: Add TP-Link TL-WR740N v6 support to 15.05.1
This patch adds support for the TP-Link TL-WR740N v6 to OpenWrt Chaos Calmer. Hardware wise, it's very similar to the TL-WR841N v10. See the forum thread [1]. Credit goes to the user 'traveler' who did the legwork and tested builds. Also thanks to Matthias Schiffer for clarifying the DEVICE_PROFILE settings. Signed-off by: Stijn Segers <francesco.borromini@inventati.org> [1]: https://forum.openwrt.org/viewtopic.php?pid=318704 git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@49225 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--target/linux/ar71xx/image/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 1a399ab9e1..cd77373ab3 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -509,6 +509,13 @@ define Device/tl-wr740n-v5
CONSOLE := ttyATH0,115200
endef
+define Device/tl-wr740n-v6
+ $(Device/tplink-4mlzma)
+ BOARDNAME := TL-WR841N-v9
+ DEVICE_PROFILE := TLWR740
+ TPLINK_HWID := 0x07400006
+endef
+
define Device/tl-wr741nd-v1
$(Device/tplink-4m)
BOARDNAME := TL-WR741ND
@@ -546,7 +553,7 @@ define Device/tl-wr743nd-v2
TPLINK_HWID := 0x07430002
CONSOLE := ttyATH0,115200
endef
-TARGET_DEVICES += tl-wr740n-v4 tl-wr740n-v5 tl-wr741nd-v1 tl-wr741nd-v2 tl-wr741nd-v4 tl-wr741nd-v5 tl-wr743nd-v2
+TARGET_DEVICES += tl-wr740n-v4 tl-wr740n-v5 tl-wr740n-v6 tl-wr741nd-v1 tl-wr741nd-v2 tl-wr741nd-v4 tl-wr741nd-v5 tl-wr743nd-v2
define Device/tl-wr841-v8
$(Device/tplink-4mlzma)