aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMirko Vogt <mirko@openwrt.org>2011-06-13 13:16:08 +0000
committerMirko Vogt <mirko@openwrt.org>2011-06-13 13:16:08 +0000
commit877522621ea595841f32adc367322b4305465966 (patch)
tree8f6647b0370488b195d59507f9c20902d02429f6
parent86b69cccdc3da00f96b6ff6bb296e198089cb76a (diff)
downloadupstream-877522621ea595841f32adc367322b4305465966.tar.gz
upstream-877522621ea595841f32adc367322b4305465966.tar.bz2
upstream-877522621ea595841f32adc367322b4305465966.zip
[package] add library 'libbsd'
This library contains core functionality usually (but obviously not always) provided by libc implementations which isneeded by OpenWrt core packages. For instance the functions 'strlcat', 'strlcpy' are not implemented in eglibc but needed by hotplug2 (udevtrigger) git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27169 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/libbsd/Makefile53
1 files changed, 53 insertions, 0 deletions
diff --git a/package/libbsd/Makefile b/package/libbsd/Makefile
new file mode 100644
index 0000000000..94c0803a44
--- /dev/null
+++ b/package/libbsd/Makefile
@@ -0,0 +1,53 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libbsd
+PKG_VERSION:=0.3.0
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://libbsd.freedesktop.org/releases
+#PKG_MD5SUM:=d0870f2de55d59c1c8419f36e8fac150
+
+include $(INCLUDE_DIR)/package.mk
+
+PKG_INSTALL:=1
+
+define Package/libbsd
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=common BSD library
+endef
+
+define Package/libbsd/description
+ This library provides useful functions commonly found on BSD systems, and lacking on others like GNU systems, thus making it easier to port projects with strong BSD origins, without needing to embed the same code over and over again on each project.
+endef
+
+define Build/InstallDev
+ $(INSTALL_DIR) \
+ $(1)/lib \
+ $(1)/usr/include
+
+ $(CP) \
+ $(PKG_INSTALL_DIR)/lib/libbsd.so* \
+ $(1)/lib/
+
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/include/* \
+ $(1)/usr/include/
+
+ ( cd $(1)/lib ; ln -s libbsd.so.$(PKG_VERSION) libbsd.so )
+endef
+
+define Package/libbsd/install
+ $(INSTALL_DIR) \
+ $(1)/lib
+
+ $(CP) \
+ $(PKG_INSTALL_DIR)/lib/libbsd.so* \
+ $(1)/lib/
+
+ ( cd $(1)/lib ; ln -s libbsd.so.$(PKG_VERSION) libbsd.so )
+endef
+
+$(eval $(call BuildPackage,libbsd))
+