aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2009-08-17 10:14:25 +0000
committerFlorian Fainelli <florian@openwrt.org>2009-08-17 10:14:25 +0000
commit76260922ffe137227bdc3bb3197d4c03ea9301d7 (patch)
treefe7fde0742e733a2ba66d1a0c6266e7ff70f54c8
parent345eed8e265adaa36d4e8487be01f6d9d34864b6 (diff)
downloadupstream-76260922ffe137227bdc3bb3197d4c03ea9301d7.tar.gz
upstream-76260922ffe137227bdc3bb3197d4c03ea9301d7.tar.bz2
upstream-76260922ffe137227bdc3bb3197d4c03ea9301d7.zip
[package] ensure CONTROL directory is created (#5683)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@17293 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--include/kernel.mk1
-rw-r--r--include/package-ipkg.mk1
2 files changed, 2 insertions, 0 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index 20377af3cf..cb62e63810 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -77,6 +77,7 @@ define ModuleAutoLoad
$(3) \
if [ -n "$$$$$$$$modules" ]; then \
mkdir -p $(2)/etc/modules.d; \
+ mkdir -p $(2)/CONTROL; \
echo "#!/bin/sh" > $(2)/CONTROL/postinst; \
echo "[ -z \"\$$$$$$$$IPKG_INSTROOT\" ] || exit 0" >> $(2)/CONTROL/postinst; \
echo ". /etc/functions.sh" >> $(2)/CONTROL/postinst; \
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index 4af052c37a..72d6d596b7 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -90,6 +90,7 @@ ifeq ($(DUMP),)
$$(IPKG_$(1)): $(STAGING_DIR)/etc/ipkg.conf $(STAMP_BUILT) $$(IDIR_$(1))/CONTROL/control
$(call Package/$(1)/install,$$(IDIR_$(1)))
+ mkdir -p $$(IDIR_$(1))/CONTROL
mkdir -p $(PACKAGE_DIR)
-find $$(IDIR_$(1)) -name 'CVS' -o -name '.svn' -o -name '.#*' | $(XARGS) rm -rf
$(RSTRIP) $$(IDIR_$(1))