aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-02-27 17:38:28 +0000
committerJonas Gorski <jogo@openwrt.org>2015-02-27 17:38:28 +0000
commit6dd3d668aeef1dc2a1bbe9dba4c17580e8fc1e43 (patch)
treed3ce04812eeacbdd02d2ca3f06f25e5ad318e3b9
parent02ce1ebb75353f98a4656efa05bebd4c28ba3153 (diff)
downloadupstream-6dd3d668aeef1dc2a1bbe9dba4c17580e8fc1e43.tar.gz
upstream-6dd3d668aeef1dc2a1bbe9dba4c17580e8fc1e43.tar.bz2
upstream-6dd3d668aeef1dc2a1bbe9dba4c17580e8fc1e43.zip
brcm63xx: allow lzma to use 32MB RAM
Most 16 MiB RAM devices don't even load elf kernels, so it's safe to assume we have at least 32 MB RAM. This fixes tftp booting with the default package set as this already produces an uncompressed kernel > 8 MiB. New limit is 8 MiB compressed / 24 MiB compressed. Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44558 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rwxr-xr-xtarget/linux/brcm63xx/image/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/target/linux/brcm63xx/image/Makefile b/target/linux/brcm63xx/image/Makefile
index d771c09370..a7d856a9e2 100755
--- a/target/linux/brcm63xx/image/Makefile
+++ b/target/linux/brcm63xx/image/Makefile
@@ -7,15 +7,17 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
-LOADADDR = 0x80010000 # RAM start + 16M
+LOADADDR = 0x80010000 # RAM start + 64K
KERNEL_ENTRY = $(LOADADDR) # Newer kernels add a jmp to the kernel_entry at the start of the binary
-RAMSIZE = 0x01000000 # 64MB
+RAMSIZE = 0x02000000 # 32MB
+LZMA_TEXT_START = 0x81800000 # 32MB - 8MB
LOADER_MAKEOPTS= \
KDIR=$(KDIR) \
LOADADDR=$(LOADADDR) \
KERNEL_ENTRY=$(KERNEL_ENTRY) \
- RAMSIZE=$(RAMSIZE)
+ RAMSIZE=$(RAMSIZE) \
+ LZMA_TEXT_START=$(LZMA_TEXT_START) \
define rootfspad/jffs2-128k
--align-rootfs
@@ -124,7 +126,6 @@ define Image/PrepareLoader
TARGET_DIR="$(BIN_DIR)" \
LOADER_DATA="$(KDIR)/vmlinux$(1).lzma" \
LOADER=$(IMG_PREFIX)-loader$(1).elf \
- LZMA_TEXT_START=0x80a00000 \
compile loader.elf
rm -f $(KDIR)/vmlinux$(1).lzma