aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2015-04-22 09:35:36 +0000
committerImre Kaloz <kaloz@openwrt.org>2015-04-22 09:35:36 +0000
commit4e7ed985dd01c7f0f880cb948445c953935579e4 (patch)
tree6338b50b97575d51e7a8f9406a1e595bca7f310e
parente126d040f0b5de966726a7302092dacf2f8c37ee (diff)
downloadupstream-4e7ed985dd01c7f0f880cb948445c953935579e4.tar.gz
upstream-4e7ed985dd01c7f0f880cb948445c953935579e4.tar.bz2
upstream-4e7ed985dd01c7f0f880cb948445c953935579e4.zip
generic/4.0: bump to final version
Linux 4.0 was released on 2014-04-12 Signed-off-by: Daniel Golle <daniel@makrotopia.org> Signed-off-by: Imre Kaloz <kaloz@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45559 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/generic/patches-4.0/204-module_strip.patch4
2 files changed, 4 insertions, 4 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index bb43e00b0b..de20fefd80 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -3,10 +3,10 @@
LINUX_RELEASE?=1
LINUX_VERSION-3.18 = .11
-LINUX_VERSION-4.0 = -rc7
+LINUX_VERSION-4.0 =
LINUX_KERNEL_MD5SUM-3.18.11 = 2def91951c9cedf7896efb864e0c090c
-LINUX_KERNEL_MD5SUM-4.0-rc7 = 26db663899b1a54397b4f184ca05f213
+LINUX_KERNEL_MD5SUM-4.0 = a86916bd12798220da9eb4a1eec3616d
ifdef KERNEL_PATCHVER
LINUX_VERSION:=$(KERNEL_PATCHVER)$(strip $(LINUX_VERSION-$(KERNEL_PATCHVER)))
diff --git a/target/linux/generic/patches-4.0/204-module_strip.patch b/target/linux/generic/patches-4.0/204-module_strip.patch
index 84cd931c3e..584839aa7a 100644
--- a/target/linux/generic/patches-4.0/204-module_strip.patch
+++ b/target/linux/generic/patches-4.0/204-module_strip.patch
@@ -109,7 +109,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
config INIT_ALL_POSSIBLE
--- a/kernel/module.c
+++ b/kernel/module.c
-@@ -2663,6 +2663,7 @@ static struct module *setup_load_info(st
+@@ -2680,6 +2680,7 @@ static struct module *setup_load_info(st
static int check_modinfo(struct module *mod, struct load_info *info, int flags)
{
@@ -117,7 +117,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
const char *modmagic = get_modinfo(info, "vermagic");
int err;
-@@ -2688,6 +2689,7 @@ static int check_modinfo(struct module *
+@@ -2705,6 +2706,7 @@ static int check_modinfo(struct module *
pr_warn("%s: module is from the staging directory, the quality "
"is unknown, you have been warned.\n", mod->name);
}