aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSven Eckelmann <sven.eckelmann@open-mesh.com>2016-05-19 20:20:44 +0200
committerSven Eckelmann <sven@narfation.org>2016-09-21 18:16:54 +0200
commit4332d73411fd8372685e57677d5b4a3a60532a11 (patch)
treec44e7a2c5e7fa216b823b23fcf513e4eed77ae07
parent2a97364ad496e90fbf3dc723a7db44096a9955f6 (diff)
downloadupstream-4332d73411fd8372685e57677d5b4a3a60532a11.tar.gz
upstream-4332d73411fd8372685e57677d5b4a3a60532a11.tar.bz2
upstream-4332d73411fd8372685e57677d5b4a3a60532a11.zip
ar71xx: Generate sysupgrade images for OpenMesh devices
Some OpenWrt based firmwares like Gluon expect that a sysupgrade image exists when a device firmware can be updated via sysupgrade. This image wasn't created until now because OpenMesh devices use the same image for factory and sysupgrade flash. Copying the image from *factory.bin to *sysupgrade.bin is therefore enough to make the sysupgrade functionality visible. Reported-by: Matthias Schiffer <mschiffer@universe-factory.net> Signed-off-by: Sven Eckelmann <sven.eckelmann@open-mesh.com>
-rw-r--r--target/linux/ar71xx/image/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 9a7acbdc72..5b0a4ecfd8 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -1847,6 +1847,9 @@ define Image/Build/OpenMesh
"$(BUILD_DIR)/fwupgrade.cfg-$(4)" "fwupgrade.cfg" \
"$(KDIR_TMP)/vmlinux-$(2).uImage" "kernel" \
"$(KDIR)/root.$(1)" "rootfs"
+ if [ -e "$(call factoryname,$(1),$(2))" ]; then \
+ cp "$(call factoryname,$(1),$(2))" "$(call sysupname,$(1),$(2))"; \
+ fi
endef