aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-06-15 14:34:00 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-06-15 14:34:00 +0000
commit415cc1c3db96ca61bb15048a5831401fc4b8dc93 (patch)
tree4a77ee36c563066353068b8afbe25ecb9a0a883a
parent1a598982c46e37bd594550ddc4b2c3a5d5b6d16e (diff)
downloadupstream-415cc1c3db96ca61bb15048a5831401fc4b8dc93.tar.gz
upstream-415cc1c3db96ca61bb15048a5831401fc4b8dc93.tar.bz2
upstream-415cc1c3db96ca61bb15048a5831401fc4b8dc93.zip
add some sanity checking
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11473 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--include/toplevel.mk2
-rw-r--r--toolchain/Makefile4
2 files changed, 4 insertions, 2 deletions
diff --git a/include/toplevel.mk b/include/toplevel.mk
index 606e3e5844..e13d66781a 100644
--- a/include/toplevel.mk
+++ b/include/toplevel.mk
@@ -45,7 +45,7 @@ prepare-tmpinfo: FORCE
touch $(TOPDIR)/tmp/.build
.config: ./scripts/config/conf prepare-tmpinfo
- @+if [ \! -f .config ]; then \
+ @+if [ -f .config ] || ! grep CONFIG_HAVE_DOT_CONFIG .config >/dev/null; then \
[ -e $(HOME)/.openwrt/defconfig ] && cp $(HOME)/.openwrt/defconfig .config; \
$(NO_TRACE_MAKE) menuconfig $(PREP_MK); \
fi
diff --git a/toolchain/Makefile b/toolchain/Makefile
index cbc726ef01..4afcc439a3 100644
--- a/toolchain/Makefile
+++ b/toolchain/Makefile
@@ -23,7 +23,8 @@ ifeq ($(CONFIG_NATIVE_TOOLCHAIN),)
$(curdir)/uClibc/install:=$(curdir)/gcc/install
endif
-$(TOOLCHAIN_DIR)/info.mk: .config
+ifneq ($(ARCH),)
+ $(TOOLCHAIN_DIR)/info.mk: .config
@for dir in $(TOOLCHAIN_DIR); do ( \
set -x; \
mkdir -p "$$dir"; \
@@ -32,6 +33,7 @@ $(TOOLCHAIN_DIR)/info.mk: .config
); done
@grep GCC_VERSION $@ >/dev/null 2>&1 || $(INSTALL_DATA) $(TOPDIR)/toolchain/info.mk $@
@touch $@
+endif
# prerequisites for the individual targets
$(curdir)/ := .config prereq