aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Baker <mbm@openwrt.org>2006-01-31 21:55:38 +0000
committerMike Baker <mbm@openwrt.org>2006-01-31 21:55:38 +0000
commit4051a0a87c963cf52c0ad1e5974739c5ec5d5fbd (patch)
treeb29a26c699c64311c74709b8aee1d954f4c0f6d0
parent2c4b4d39a77494dd432b192ba58ce1f7158e7fcb (diff)
downloadupstream-4051a0a87c963cf52c0ad1e5974739c5ec5d5fbd.tar.gz
upstream-4051a0a87c963cf52c0ad1e5974739c5ec5d5fbd.tar.bz2
upstream-4051a0a87c963cf52c0ad1e5974739c5ec5d5fbd.zip
fix "make target/linux/package/*-*" targets
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@3103 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--target/Makefile2
-rw-r--r--target/linux/Makefile2
-rw-r--r--target/linux/kernel.mk5
3 files changed, 9 insertions, 0 deletions
diff --git a/target/Makefile b/target/Makefile
index ec3b659724..e066fa9d39 100644
--- a/target/Makefile
+++ b/target/Makefile
@@ -35,3 +35,5 @@ linux-imagebuilder:
@$(TRACE) target/linux/imagebuilder
$(MAKE) -C linux imagebuilder
+linux/package/%:
+ $(MAKE) -C $(TOPDIR)/target/linux $(patsubst linux/%,%,$@)
diff --git a/target/linux/Makefile b/target/linux/Makefile
index 2fff3b33af..626587b5b0 100644
--- a/target/linux/Makefile
+++ b/target/linux/Makefile
@@ -45,6 +45,8 @@ compile: $(1)/$(2)-compile
rebuild: $(1)/$(2)-rebuild
$(BIN_DIR)/$(IB_NAME).tar.bz2 install: $(1)/$(2)-image
install-ib: $(1)/$(2)-install-ib
+package/%:
+ $(MAKE) -C $(2)-$(1) BOARD="$(2)" $$@
endif
.PHONY: $(1)/$(2)-clean $(1)/$(2)-prepare $(1)/$(2)-compile $(1)/$(2)-rebuild $(1)/$(2)-install $(1)/$(2)-image $(1)/$(2)-install-ib
diff --git a/target/linux/kernel.mk b/target/linux/kernel.mk
index b1ac9473c7..5406fae20e 100644
--- a/target/linux/kernel.mk
+++ b/target/linux/kernel.mk
@@ -114,3 +114,8 @@ clean:
rm -f $(STAMP_DIR)/.linux-compile
rm -rf $(LINUX_BUILD_DIR)
rm -f $(TARGETS)
+
+package/%:
+ $(MAKE) -C $(TOPDIR)/target/linux/package \
+ $(KPKG_MAKEOPTS) \
+ $(patsubst package/%,%,$@)