aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-10-15 14:38:36 +0000
committerJohn Crispin <blogic@openwrt.org>2015-10-15 14:38:36 +0000
commit3b15d86f3c2939b30dd9afb4a5fa8f9f6560ac92 (patch)
tree3629c253019aec1a0c90a8c75970c73791f8ed57
parent7386b196138dc08b98252374bea53fdddc03445b (diff)
downloadupstream-3b15d86f3c2939b30dd9afb4a5fa8f9f6560ac92.tar.gz
upstream-3b15d86f3c2939b30dd9afb4a5fa8f9f6560ac92.tar.bz2
upstream-3b15d86f3c2939b30dd9afb4a5fa8f9f6560ac92.zip
mcs814x: use firmware partition splitter on dLAN USB Extender
to avoid editing the dts every time the kernel size changes. uImage is now bigger than 1MB. Pad uImage to 64k erase block size. Signed-off-by: Günther Kelleter <guenther.kelleter@devolo.de> Backport of r46648 git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@47194 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--target/linux/mcs814x/config-3.184
-rw-r--r--target/linux/mcs814x/files-3.18/arch/arm/boot/dts/dlan-usb-extender.dts8
-rw-r--r--target/linux/mcs814x/image/Makefile2
3 files changed, 5 insertions, 9 deletions
diff --git a/target/linux/mcs814x/config-3.18 b/target/linux/mcs814x/config-3.18
index e57f5ff013..427a7c92ce 100644
--- a/target/linux/mcs814x/config-3.18
+++ b/target/linux/mcs814x/config-3.18
@@ -159,6 +159,10 @@ CONFIG_MODULES_USE_ELF_REL=y
# CONFIG_MTD_IMPA7 is not set
CONFIG_MTD_JEDECPROBE=y
CONFIG_MTD_PHYSMAP=y
+# CONFIG_MTD_ROOTFS_SPLIT is not set
+CONFIG_MTD_SPLIT_FIRMWARE=y
+CONFIG_MTD_SPLIT_FIRMWARE_NAME="linux"
+CONFIG_MTD_SPLIT_UIMAGE_FW=y
CONFIG_MULTI_IRQ_HANDLER=y
CONFIG_NEED_DMA_MAP_STATE=y
CONFIG_NEED_KUSER_HELPERS=y
diff --git a/target/linux/mcs814x/files-3.18/arch/arm/boot/dts/dlan-usb-extender.dts b/target/linux/mcs814x/files-3.18/arch/arm/boot/dts/dlan-usb-extender.dts
index 0c85b94c0a..59830e8843 100644
--- a/target/linux/mcs814x/files-3.18/arch/arm/boot/dts/dlan-usb-extender.dts
+++ b/target/linux/mcs814x/files-3.18/arch/arm/boot/dts/dlan-usb-extender.dts
@@ -48,14 +48,6 @@
reg = <0x40000 0x10000>;
};
partition@50000 {
- label = "kernel";
- reg = <0x50000 0x100000>;
- };
- partition@150000 {
- label = "rootfs";
- reg = <0x150000 0x3C0000>;
- };
- partition@50001 {
label = "linux";
reg = <0x50000 0x4C0000>;
};
diff --git a/target/linux/mcs814x/image/Makefile b/target/linux/mcs814x/image/Makefile
index 4c8af97d22..74f8ad48af 100644
--- a/target/linux/mcs814x/image/Makefile
+++ b/target/linux/mcs814x/image/Makefile
@@ -30,7 +30,7 @@ define Image/Build/DTB
endef
define Image/Build/Profile/dLAN_USB_Extender
- dd if=$(KDIR)/uImage-dlan-usb-extender bs=1M conv=sync of=$(KDIR)/$(IMG_PREFIX)-dlan-usb-extender-upgrade-$(1).bin
+ dd if=$(KDIR)/uImage-dlan-usb-extender bs=64k conv=sync of=$(KDIR)/$(IMG_PREFIX)-dlan-usb-extender-upgrade-$(1).bin
cat $(KDIR)/root.$(1) >> $(KDIR)/$(IMG_PREFIX)-dlan-usb-extender-upgrade-$(1).bin
cp $(KDIR)/$(IMG_PREFIX)-dlan-usb-extender-upgrade-$(1).bin $(BIN_DIR)/
endef