aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-03-04 11:37:28 +0000
committerLuka Perkov <luka@openwrt.org>2013-03-04 11:37:28 +0000
commit29f41f3be0a36f4e283149a38d2ddcdfbc19fdfe (patch)
tree6645f21e280d4bf84aa85c1546b4e9e317aba00a
parent2a6ca561577fb197c6d83c5f523657f3a673508f (diff)
downloadupstream-29f41f3be0a36f4e283149a38d2ddcdfbc19fdfe.tar.gz
upstream-29f41f3be0a36f4e283149a38d2ddcdfbc19fdfe.tar.bz2
upstream-29f41f3be0a36f4e283149a38d2ddcdfbc19fdfe.zip
ar71xx: enable building ramdisk images for WZRHPG30XNH board types
Signed-off-by: Luka Perkov <luka@openwrt.org> Acked-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@35874 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--target/linux/ar71xx/image/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 63abfe7ace..20caff83f5 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -284,6 +284,10 @@ define Image/Build/WZRHPG30XNH
fi
endef
+define Image/Build/WZRHPG30XNH/initramfs
+ $(call MkuImageLzma/initramfs,$(2),$(3) $(4))
+endef
+
define Image/Build/WHRHPG300N
$(call MkuImageLzma,$(2),$(3) $(4))
$(call Sysupgrade/KRuImage,$(1),$(2),1048576,2818048)