aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2007-07-18 14:40:57 +0000
committerFlorian Fainelli <florian@openwrt.org>2007-07-18 14:40:57 +0000
commit21259095f999f70f9dd1fb947be00afb56df3da9 (patch)
treed39cda1ff635c2785dfcc49d4898e0654602a4d3
parente84915d1fceef35dfc14c179b2714951e28ac3a9 (diff)
downloadupstream-21259095f999f70f9dd1fb947be00afb56df3da9.tar.gz
upstream-21259095f999f70f9dd1fb947be00afb56df3da9.tar.bz2
upstream-21259095f999f70f9dd1fb947be00afb56df3da9.zip
Fix the tgz image build
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8042 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--include/image.mk1
-rw-r--r--target/linux/adm5120-2.6/image/Makefile2
2 files changed, 3 insertions, 0 deletions
diff --git a/include/image.mk b/include/image.mk
index 5fc87efa1d..c56e7cf193 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -57,6 +57,7 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
ifeq ($(CONFIG_TARGET_ROOTFS_TGZ),y)
define Image/mkfs/tgz
$(TAR) -zcf $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-rootfs.tgz --owner=root --group=root -C $(BUILD_DIR)/root/ .
+ $(call Image/Build,tgz)
endef
endif
else
diff --git a/target/linux/adm5120-2.6/image/Makefile b/target/linux/adm5120-2.6/image/Makefile
index d76e1e1fee..b9ae44ecb4 100644
--- a/target/linux/adm5120-2.6/image/Makefile
+++ b/target/linux/adm5120-2.6/image/Makefile
@@ -90,6 +90,7 @@ define Image/Build
# this line is here intentionally
ifneq ($(1),jffs2-256k)
ifneq ($(1),jffs2-128k)
+ifneq ($(1),tgz)
$(call Image/Build/Compex,$(1),wp54g-wrt,$(patsubst jffs2-%,jffs2,$(1)),WP54G-WRT)
ifeq ($(CONFIG_DEVEL),y)
$(call Image/Build/Edimax,$(1),br-6104k,$(patsubst jffs2-%,jffs2,$(1)),BR-6104K)
@@ -119,6 +120,7 @@ ifeq ($(CONFIG_DEVEL),y)
endif
endif
endif
+endif
ifeq ($(1),tgz)
$(call Image/Build/RouterBoard)
endif