aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafał Miłecki <zajec5@gmail.com>2016-03-11 08:54:13 +0000
committerRafał Miłecki <zajec5@gmail.com>2016-03-11 08:54:13 +0000
commit1ce37b76d27eab75b76ebaea9273ac9fdd5e4751 (patch)
tree9513ef6f42240522509a278d5290317ec45e1303
parent39b3d913c41f0b4885e158fb3d3f36b93a9d05de (diff)
downloadupstream-1ce37b76d27eab75b76ebaea9273ac9fdd5e4751.tar.gz
upstream-1ce37b76d27eab75b76ebaea9273ac9fdd5e4751.tar.bz2
upstream-1ce37b76d27eab75b76ebaea9273ac9fdd5e4751.zip
brcm47xx: image: switch Netgear WGT634U to the new building system
Signed-off-by: Rafał Miłecki <zajec5@gmail.com> Backport of r48973 git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@49001 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--target/linux/brcm47xx/image/Makefile19
1 files changed, 13 insertions, 6 deletions
diff --git a/target/linux/brcm47xx/image/Makefile b/target/linux/brcm47xx/image/Makefile
index 0d71d3f191..e8598fa76d 100644
--- a/target/linux/brcm47xx/image/Makefile
+++ b/target/linux/brcm47xx/image/Makefile
@@ -34,11 +34,6 @@ endif
$(call prepare_generic_squashfs,$(KDIR)/fs_mark)
endef
-define Image/Build/wgt634u
- dd if=$(KDIR)/loader.elf of=$(BIN_DIR)/$(IMG_PREFIX)-wgt634u-$(2).bin bs=131072 conv=sync
- cat $(BIN_DIR)/$(IMG_PREFIX)-$(1).trx >> $(BIN_DIR)/$(IMG_PREFIX)-wgt634u-$(2).bin
-endef
-
# $(1): filesystem type.
# $(2): device model (used for output file).
# $(3): pattern (device specific magic).
@@ -137,6 +132,12 @@ define Build/netgear-chk
mv $@.new $@
endef
+define Build/prepend-with-elf
+ mv $@ $@.old
+ dd if=$(KDIR)/loader.elf of=$@ bs=131072 conv=sync
+ cat $@.old >> $@
+endef
+
define Build/tailed-bin
echo $(BIN_TAIL) >> $@
endef
@@ -242,7 +243,6 @@ endif
# $(1): filesystem type.
define Image/Build/legacy/devices-with-128k-blocks
$(call Image/Build/trxV2,$(1),wrt54g3gv2-vf,3G2V,3.00.24,$(patsubst jffs2-%,jffs2,$(1)),6)
- $(call Image/Build/wgt634u,$(1),$(patsubst jffs2-%,jffs2,$(1)))
endef
# $(1): filesystem type.
@@ -286,6 +286,12 @@ define Device/linksys-wrtsl54gs
VERSION := 2.08.1
endef
+define Device/netgear-wgt634u
+ FILESYSTEMS := $(FS_128K)
+ IMAGES := bin
+ IMAGE/bin := trx-with-loader | prepend-with-elf
+endef
+
define Device/usrobotics-usr5461
IMAGES := bin
IMAGE/bin := trx-with-loader | usrobotics-bin
@@ -298,6 +304,7 @@ ifeq ($(SUBTARGET),legacy)
huawei-e970 \
linksys-wrt54gs \
linksys-wrtsl54gs \
+ netgear-wgt634u \
usrobotics-usr5461
$(eval $(call AsusDevice,wl-300g,WL300g ))