aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-12-27 13:03:19 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-12-27 13:03:19 +0000
commit17ace69bf77eb104d0b555496297eb537cb17679 (patch)
treed19828256aed657d8cfd22f86c5b37f6ab712630
parent9d94ace19a395f30a969728f81d77eb0b4bbd0ba (diff)
downloadupstream-17ace69bf77eb104d0b555496297eb537cb17679.tar.gz
upstream-17ace69bf77eb104d0b555496297eb537cb17679.tar.bz2
upstream-17ace69bf77eb104d0b555496297eb537cb17679.zip
image.mk: make ubinize.cfg optional
When using UbinizeImage with ubifs rootfs, ubinize.cfg is no longer needed. Yet, the absance of ubinize.cfg would make the build process abort with an error. Fix that by checking if ubinize.cfg is present and do no not call the "classic" ubinize image generation if it isn't. Signed-off-by: Daniel Golle <daniel@makrotopia.org> [missing new-line before UbinizeImage added itentionally] git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43788 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--include/image.mk5
1 files changed, 3 insertions, 2 deletions
diff --git a/include/image.mk b/include/image.mk
index d6c8b7af87..7375bf563f 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -146,6 +146,7 @@ ifneq ($(CONFIG_NAND_SUPPORT),)
(cd "$(KDIR_TMP)"; $(TAR) cvf \
"$(BIN_DIR)/$(IMG_PREFIX)-$(1)-$(2)-sysupgrade.tar" sysupgrade-$(1))
endef
+
# $(1) board name
# $(2) ubinize-image options (e.g. --uboot-env and/or --kernel kernelimage)
# $(3) rootfstype (e.g. squashfs or ubifs)
@@ -193,10 +194,10 @@ ifneq ($(CONFIG_TARGET_ROOTFS_UBIFS),)
$(call Image/Build,ubifs)
ifneq ($($(PROFILE)_UBI_OPTS)$(UBI_OPTS),)
- $(call Image/mkfs/ubifs/generate,)
+ $(if $(wildcard ./ubinize.cfg),$(call Image/mkfs/ubifs/generate,))
$(if $(wildcard ./ubinize-overlay.cfg),$(call Image/mkfs/ubifs/generate,-overlay))
endif
- $(call Image/Build,ubi)
+ $(if $(wildcard ./ubinize.cfg),$(call Image/Build,ubi))
endef
endif