aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-02-27 23:46:34 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-02-27 23:46:34 +0000
commit1074b896e4eda92f163ad8da89d41f63481e7cfb (patch)
tree118b4a3e8f4a42cd24392b8a339ed781f3c90540
parent79987affe295be98103e5c4bda96f0eea69677c1 (diff)
downloadupstream-1074b896e4eda92f163ad8da89d41f63481e7cfb.tar.gz
upstream-1074b896e4eda92f163ad8da89d41f63481e7cfb.tar.bz2
upstream-1074b896e4eda92f163ad8da89d41f63481e7cfb.zip
move ccache to tools/ and fix potential dependency issue
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6413 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--toolchain/Makefile1
-rw-r--r--tools/Makefile3
-rw-r--r--tools/ccache/Makefile (renamed from toolchain/ccache/Makefile)0
3 files changed, 2 insertions, 2 deletions
diff --git a/toolchain/Makefile b/toolchain/Makefile
index 4832a657df..7773c32c31 100644
--- a/toolchain/Makefile
+++ b/toolchain/Makefile
@@ -10,7 +10,6 @@ include $(TOPDIR)/rules.mk
TARGETS-y:=kernel-headers
TARGETS-$(CONFIG_GDB) += gdb
-TARGETS-$(CONFIG_CCACHE) += ccache
ifeq ($(CONFIG_NATIVE_TOOLCHAIN),)
TARGETS-y+=binutils gcc uClibc
endif
diff --git a/tools/Makefile b/tools/Makefile
index d03ab38ee3..8c5f699d32 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -8,6 +8,7 @@
#
include $(TOPDIR)/rules.mk
TARGETS-y:=sed sstrip ipkg-utils ext2fs squashfs mtd-utils lzma mkimage firmware-utils
+TARGETS-$(CONFIG_CCACHE) += ccache
TARGETS_DOWNLOAD:=$(patsubst %,%-download,$(TARGETS-y))
TARGETS_PREPARE:=$(patsubst %,%-prepare,$(TARGETS-y))
@@ -28,7 +29,7 @@ ifneq ($(shell $(SCRIPT_DIR)/timestamp.pl -p . $(STAMP)),$(STAMP))
$(STAMP): $(TARGETS_INSTALL)
endif
-$(STAMP):
+$(STAMP): $(TOPDIR)/.config
mkdir -p $(shell dirname $@)
touch $@
diff --git a/toolchain/ccache/Makefile b/tools/ccache/Makefile
index e8e85b442a..e8e85b442a 100644
--- a/toolchain/ccache/Makefile
+++ b/tools/ccache/Makefile