aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2016-03-20 14:45:02 +0000
committerJohn Crispin <blogic@openwrt.org>2016-03-20 14:45:02 +0000
commit09ccef95a9305bede689e86f4b8e4ae315edbd4a (patch)
tree2b6f71c95ec8e51c4cae5c21da0e229a13319612
parent5a89d0fcb54ae0d5298cf79fa700a0172f550abb (diff)
downloadupstream-09ccef95a9305bede689e86f4b8e4ae315edbd4a.tar.gz
upstream-09ccef95a9305bede689e86f4b8e4ae315edbd4a.tar.bz2
upstream-09ccef95a9305bede689e86f4b8e4ae315edbd4a.zip
CC: version.mk and image-config.in: adjust to 15.05.1
* Adjust the default version number in include/version.mk to 15.05.1 * Copy the correct download repo location from include/version.mk to base-files/image-config.in After the change to version.mk, new builds made from CC sources will have opkg config that downloads from the recent 15.05.1 packages repo instead of the ancient 15.05 packages repo. The change to image-config.in ensures that if somebody uses VERSIONOPT config options in .config, he will get the correct download repo address (instead of trunk snapshots). Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi> git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@49053 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--include/version.mk2
-rw-r--r--package/base-files/image-config.in2
2 files changed, 2 insertions, 2 deletions
diff --git a/include/version.mk b/include/version.mk
index 9348a241be..ddce935f3b 100644
--- a/include/version.mk
+++ b/include/version.mk
@@ -21,7 +21,7 @@ qstrip_escape=$(subst ','\'',$(call qstrip,$(1)))
#'
VERSION_NUMBER:=$(call qstrip_escape,$(CONFIG_VERSION_NUMBER))
-VERSION_NUMBER:=$(if $(VERSION_NUMBER),$(VERSION_NUMBER),15.05)
+VERSION_NUMBER:=$(if $(VERSION_NUMBER),$(VERSION_NUMBER),15.05.1)
VERSION_CODE:=$(call qstrip_escape,$(CONFIG_VERSION_NUMBER))
VERSION_CODE:=$(if $(VERSION_CODE),$(VERSION_CODE),Chaos Calmer)
diff --git a/package/base-files/image-config.in b/package/base-files/image-config.in
index 495300d839..0dfd6f6caa 100644
--- a/package/base-files/image-config.in
+++ b/package/base-files/image-config.in
@@ -170,7 +170,7 @@ if VERSIONOPT
config VERSION_REPO
string
prompt "Release repository"
- default "http://downloads.openwrt.org/snapshots/trunk/%S/packages"
+ default "http://downloads.openwrt.org/%n/%v/%S/packages"
help
This is the repository address embedded in the image, it defaults
to the trunk snapshot repo; the url may contain the following placeholders: