aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2014-11-08 12:27:41 +0000
committerSteven Barth <steven@midlink.org>2014-11-08 12:27:41 +0000
commite335bc35d4345e14f8ad9947febe1f8c024d430e (patch)
treef4df06adfee9803e317e230cc2f04af3fafdc794
parent62ca685194e2547b9159ebe220051c26fe4b7ece (diff)
downloadupstream-e335bc35d4345e14f8ad9947febe1f8c024d430e.tar.gz
upstream-e335bc35d4345e14f8ad9947febe1f8c024d430e.tar.bz2
upstream-e335bc35d4345e14f8ad9947febe1f8c024d430e.zip
netifd: fix default ORO for 6rd
Signed-off-by: Steven Barth <steven@midlink.org> git-svn-id: svn://svn.openwrt.org/openwrt/branches/barrier_breaker@43215 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/network/config/netifd/Makefile2
-rwxr-xr-xpackage/network/config/netifd/files/lib/netifd/proto/dhcp.sh2
2 files changed, 2 insertions, 2 deletions
diff --git a/package/network/config/netifd/Makefile b/package/network/config/netifd/Makefile
index f4bd6be549..be0114f455 100644
--- a/package/network/config/netifd/Makefile
+++ b/package/network/config/netifd/Makefile
@@ -1,7 +1,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=netifd
-PKG_VERSION:=2014-09-08
+PKG_VERSION:=2014-09-08.1
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git
diff --git a/package/network/config/netifd/files/lib/netifd/proto/dhcp.sh b/package/network/config/netifd/files/lib/netifd/proto/dhcp.sh
index b14f7be92d..4067460675 100755
--- a/package/network/config/netifd/files/lib/netifd/proto/dhcp.sh
+++ b/package/network/config/netifd/files/lib/netifd/proto/dhcp.sh
@@ -39,7 +39,7 @@ proto_dhcp_setup() {
[ "$broadcast" = 1 ] && broadcast="-B" || broadcast=
[ -n "$clientid" ] && clientid="-x 0x3d:${clientid//:/}" || clientid="-C"
[ -n "$iface6rd" ] && proto_export "IFACE6RD=$iface6rd"
- [ -n "$iface6rd" ] && append dhcpopts "-O 212"
+ [ "$iface6rd" != 0 -a -f /lib/netifd/proto/6rd.sh ] && append dhcpopts "-O 212"
[ -n "$zone6rd" ] && proto_export "ZONE6RD=$zone6rd"
[ -n "$zone" ] && proto_export "ZONE=$zone"
[ "$delegate" = "0" ] && proto_export "IFACE6RD_DELEGATE=0"