aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-02-13 11:59:16 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-02-13 11:59:16 +0000
commitcd30f34da529d0d80782c0e5dccd50bba656f8aa (patch)
tree6fdf8ad410aa8feb8934239d6c1dba84f2f3bef2
parent4a54acf279d44111a46129ca3f08a68e41a18b04 (diff)
downloadupstream-cd30f34da529d0d80782c0e5dccd50bba656f8aa.tar.gz
upstream-cd30f34da529d0d80782c0e5dccd50bba656f8aa.tar.bz2
upstream-cd30f34da529d0d80782c0e5dccd50bba656f8aa.zip
BB: build: improve feed handling for opkg.conf
- Consider not installed feeds as well - Add option to decide whether to comment disabled feeds Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> Backport of r42931 git-svn-id: svn://svn.openwrt.org/openwrt/branches/barrier_breaker@44441 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--include/feeds.mk4
-rw-r--r--package/base-files/image-config.in11
-rw-r--r--package/system/opkg/Makefile2
3 files changed, 13 insertions, 4 deletions
diff --git a/include/feeds.mk b/include/feeds.mk
index 97b14491f0..695b03b145 100644
--- a/include/feeds.mk
+++ b/include/feeds.mk
@@ -10,10 +10,12 @@
FEEDS_AVAILABLE:=$(shell $(SCRIPT_DIR)/feeds list -n)
FEEDS_INSTALLED:=$(notdir $(wildcard $(TOPDIR)/package/feeds/*))
FEEDS_ENABLED:=$(foreach feed,$(FEEDS_INSTALLED),$(if $(CONFIG_FEED_$(feed)),$(feed)))
-FEEDS_DISABLED:=$(filter-out $(FEEDS_ENABLED),$(FEEDS_INSTALLED))
+FEEDS_DISABLED:=$(filter-out $(FEEDS_ENABLED),$(FEEDS_AVAILABLE))
PKG_CONFIG_DEPENDS += \
CONFIG_PER_FEED_REPO \
+ CONFIG_PER_FEED_REPO_ADD_DISABLED \
+ CONFIG_PER_FEED_REPO_ADD_COMMENTED \
$(foreach feed,$(FEEDS_INSTALLED),CONFIG_FEED_$(feed))
# 1: package name
diff --git a/package/base-files/image-config.in b/package/base-files/image-config.in
index 67604cdd54..c679a5b33a 100644
--- a/package/base-files/image-config.in
+++ b/package/base-files/image-config.in
@@ -217,11 +217,18 @@ menuconfig PER_FEED_REPO
for the core packages and each enabled feed.
config PER_FEED_REPO_ADD_DISABLED
- bool "Add installed but disabled feeds to opkg.conf"
+ bool "Add available but not enabled feeds to opkg.conf"
default y
depends on PER_FEED_REPO
help
- Add installed but disabled feeds as commented out source lines to opkg.conf.
+ Add not installed or disabled feeds from feeds.conf to opkg.conf.
+
+ config PER_FEED_REPO_ADD_COMMENTED
+ bool "Comment out not enabled feeds"
+ default y
+ depends on PER_FEED_REPO && PER_FEED_REPO_ADD_DISABLED
+ help
+ Add not enabled feeds as commented out source lines to opkg.conf.
source "tmp/.config-feeds.in"
diff --git a/package/system/opkg/Makefile b/package/system/opkg/Makefile
index 8a63fb4352..6dd3f31818 100644
--- a/package/system/opkg/Makefile
+++ b/package/system/opkg/Makefile
@@ -113,7 +113,7 @@ define Package/opkg/Default/install
done
ifneq ($(CONFIG_PER_FEED_REPO_ADD_DISABLED),)
for d in $(FEEDS_DISABLED); do \
- echo "# src/gz %n_$$$$d %U/$$$$d" >> $(1)/etc/opkg.conf; \
+ echo "$(if $(CONFIG_PER_FEED_REPO_ADD_COMMENTED),# )src/gz %n_$$$$d %U/$$$$d" >> $(1)/etc/opkg.conf; \
done
endif
endif