aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-06-13 09:34:03 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-06-13 09:34:03 +0000
commita045629b04d5f328044ac2b0dddb7e11e6585336 (patch)
tree00184f86c34019e00388d56a740cbc09b805b754
parent90ee91f93d55bc225d127d25107e8541fb482ee2 (diff)
downloadupstream-a045629b04d5f328044ac2b0dddb7e11e6585336.tar.gz
upstream-a045629b04d5f328044ac2b0dddb7e11e6585336.tar.bz2
upstream-a045629b04d5f328044ac2b0dddb7e11e6585336.zip
kernel: fix pkt_type filter mask for packet sockets
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41178 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/kernel/mac80211/Makefile2
-rw-r--r--target/linux/generic/patches-3.10/630-packet_socket_type.patch2
-rw-r--r--target/linux/generic/patches-3.12/630-packet_socket_type.patch2
-rw-r--r--target/linux/generic/patches-3.13/630-packet_socket_type.patch2
-rw-r--r--target/linux/generic/patches-3.14/630-packet_socket_type.patch2
-rw-r--r--target/linux/generic/patches-3.3/630-packet_socket_type.patch2
-rw-r--r--target/linux/generic/patches-3.6/630-packet_socket_type.patch2
-rw-r--r--target/linux/generic/patches-3.8/630-packet_socket_type.patch2
-rw-r--r--target/linux/generic/patches-3.9/630-packet_socket_type.patch2
9 files changed, 9 insertions, 9 deletions
diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
index e260993b89..9ea01a8e78 100644
--- a/package/kernel/mac80211/Makefile
+++ b/package/kernel/mac80211/Makefile
@@ -1447,7 +1447,7 @@ endif
config-$(call config_package,lib80211) += LIB80211 LIB80211_CRYPT_WEP LIB80211_CRYPT_CCMP LIB80211_CRYPT_TKIP
config-$(call config_package,ath) += ATH_CARDS ATH_COMMON
-config-$(CONFIG_PACKAGE_ATH_DEBUG) += ATH_DEBUG ATH10K_DEBUG
+config-$(CONFIG_PACKAGE_ATH_DEBUG) += ATH_DEBUG ATH10K_DEBUG ATH9K_TX99
config-$(CONFIG_PACKAGE_ATH_DFS) += ATH9K_DFS_CERTIFIED ATH10K_DFS_CERTIFIED
config-$(call config_package,ath9k) += ATH9K
diff --git a/target/linux/generic/patches-3.10/630-packet_socket_type.patch b/target/linux/generic/patches-3.10/630-packet_socket_type.patch
index 14878d3820..3a3c3bb84f 100644
--- a/target/linux/generic/patches-3.10/630-packet_socket_type.patch
+++ b/target/linux/generic/patches-3.10/630-packet_socket_type.patch
@@ -102,7 +102,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
+ return -EINVAL;
+ if (copy_from_user(&val, optval, sizeof(val)))
+ return -EFAULT;
-+ po->pkt_type = val & ~PACKET_LOOPBACK;
++ po->pkt_type = val & ~BIT(PACKET_LOOPBACK);
+ return 0;
+ }
default:
diff --git a/target/linux/generic/patches-3.12/630-packet_socket_type.patch b/target/linux/generic/patches-3.12/630-packet_socket_type.patch
index 1e915f61fb..60e840153b 100644
--- a/target/linux/generic/patches-3.12/630-packet_socket_type.patch
+++ b/target/linux/generic/patches-3.12/630-packet_socket_type.patch
@@ -102,7 +102,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
+ return -EINVAL;
+ if (copy_from_user(&val, optval, sizeof(val)))
+ return -EFAULT;
-+ po->pkt_type = val & ~PACKET_LOOPBACK;
++ po->pkt_type = val & ~BIT(PACKET_LOOPBACK);
+ return 0;
+ }
default:
diff --git a/target/linux/generic/patches-3.13/630-packet_socket_type.patch b/target/linux/generic/patches-3.13/630-packet_socket_type.patch
index 1e915f61fb..60e840153b 100644
--- a/target/linux/generic/patches-3.13/630-packet_socket_type.patch
+++ b/target/linux/generic/patches-3.13/630-packet_socket_type.patch
@@ -102,7 +102,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
+ return -EINVAL;
+ if (copy_from_user(&val, optval, sizeof(val)))
+ return -EFAULT;
-+ po->pkt_type = val & ~PACKET_LOOPBACK;
++ po->pkt_type = val & ~BIT(PACKET_LOOPBACK);
+ return 0;
+ }
default:
diff --git a/target/linux/generic/patches-3.14/630-packet_socket_type.patch b/target/linux/generic/patches-3.14/630-packet_socket_type.patch
index d0247af83f..4f3f5e8b7f 100644
--- a/target/linux/generic/patches-3.14/630-packet_socket_type.patch
+++ b/target/linux/generic/patches-3.14/630-packet_socket_type.patch
@@ -102,7 +102,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
+ return -EINVAL;
+ if (copy_from_user(&val, optval, sizeof(val)))
+ return -EFAULT;
-+ po->pkt_type = val & ~PACKET_LOOPBACK;
++ po->pkt_type = val & ~BIT(PACKET_LOOPBACK);
+ return 0;
+ }
default:
diff --git a/target/linux/generic/patches-3.3/630-packet_socket_type.patch b/target/linux/generic/patches-3.3/630-packet_socket_type.patch
index 231b745c6a..bcb399141f 100644
--- a/target/linux/generic/patches-3.3/630-packet_socket_type.patch
+++ b/target/linux/generic/patches-3.3/630-packet_socket_type.patch
@@ -110,7 +110,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
+ return -EINVAL;
+ if (copy_from_user(&val, optval, sizeof(val)))
+ return -EFAULT;
-+ po->pkt_type = val & ~PACKET_LOOPBACK;
++ po->pkt_type = val & ~BIT(PACKET_LOOPBACK);
+ return 0;
+ }
default:
diff --git a/target/linux/generic/patches-3.6/630-packet_socket_type.patch b/target/linux/generic/patches-3.6/630-packet_socket_type.patch
index a630d1d823..b43c14594f 100644
--- a/target/linux/generic/patches-3.6/630-packet_socket_type.patch
+++ b/target/linux/generic/patches-3.6/630-packet_socket_type.patch
@@ -110,7 +110,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
+ return -EINVAL;
+ if (copy_from_user(&val, optval, sizeof(val)))
+ return -EFAULT;
-+ po->pkt_type = val & ~PACKET_LOOPBACK;
++ po->pkt_type = val & ~BIT(PACKET_LOOPBACK);
+ return 0;
+ }
default:
diff --git a/target/linux/generic/patches-3.8/630-packet_socket_type.patch b/target/linux/generic/patches-3.8/630-packet_socket_type.patch
index 0671a28e9b..d1a9ee23a8 100644
--- a/target/linux/generic/patches-3.8/630-packet_socket_type.patch
+++ b/target/linux/generic/patches-3.8/630-packet_socket_type.patch
@@ -102,7 +102,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
+ return -EINVAL;
+ if (copy_from_user(&val, optval, sizeof(val)))
+ return -EFAULT;
-+ po->pkt_type = val & ~PACKET_LOOPBACK;
++ po->pkt_type = val & ~BIT(PACKET_LOOPBACK);
+ return 0;
+ }
default:
diff --git a/target/linux/generic/patches-3.9/630-packet_socket_type.patch b/target/linux/generic/patches-3.9/630-packet_socket_type.patch
index 9b700f5150..ff57bb76c2 100644
--- a/target/linux/generic/patches-3.9/630-packet_socket_type.patch
+++ b/target/linux/generic/patches-3.9/630-packet_socket_type.patch
@@ -102,7 +102,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
+ return -EINVAL;
+ if (copy_from_user(&val, optval, sizeof(val)))
+ return -EFAULT;
-+ po->pkt_type = val & ~PACKET_LOOPBACK;
++ po->pkt_type = val & ~BIT(PACKET_LOOPBACK);
+ return 0;
+ }
default: