aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-12-11 13:20:19 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-12-11 13:20:19 +0000
commit9c8f1a4da5c329f9686334100ceaceafd0783a1a (patch)
treef7466fa3e2a6ebd6b6862f7a420e5aa4cac349eb
parent2a394fb653a37505fb407f1d2df78ab75ac14519 (diff)
downloadupstream-9c8f1a4da5c329f9686334100ceaceafd0783a1a.tar.gz
upstream-9c8f1a4da5c329f9686334100ceaceafd0783a1a.tar.bz2
upstream-9c8f1a4da5c329f9686334100ceaceafd0783a1a.zip
add a host package for xz
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@24481 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--tools/Makefile2
-rw-r--r--tools/xz/Makefile18
2 files changed, 19 insertions, 1 deletions
diff --git a/tools/Makefile b/tools/Makefile
index e96167b4e7..3b3f187c4d 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -17,7 +17,7 @@ endif
tools-y += m4 autoconf automake bison pkg-config sed mklibs
tools-y += sstrip ipkg-utils genext2fs e2fsprogs mtd-utils mkimage
tools-y += firmware-utils patch-cmdline quilt yaffs2 flock
-tools-y += xorg-macros
+tools-y += xorg-macros xz
tools-$(CONFIG_TARGET_orion_generic) += wrt350nv2-builder upslug2
tools-$(CONFIG_TARGET_x86) += qemu
ifneq ($(CONFIG_TARGET_ar71xx),)
diff --git a/tools/xz/Makefile b/tools/xz/Makefile
new file mode 100644
index 0000000000..5689e18d44
--- /dev/null
+++ b/tools/xz/Makefile
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=xz
+PKG_VERSION:=5.0.0
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://tukaani.org/xz
+PKG_MD5SUM:=0652c09fdbb93ae2ce78c1368ffda612
+
+include $(INCLUDE_DIR)/host-build.mk
+
+$(eval $(call HostBuild))