aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2006-02-22 14:58:45 +0000
committerFlorian Fainelli <florian@openwrt.org>2006-02-22 14:58:45 +0000
commit9c6f4e54fbb93e2ca036d4f93b64d59698d2e28b (patch)
tree549b1f6918a201105dd8b134d181598c1a318301
parentb397d5dc3fda4933812b888a4141ec0f36f302da (diff)
downloadupstream-9c6f4e54fbb93e2ca036d4f93b64d59698d2e28b.tar.gz
upstream-9c6f4e54fbb93e2ca036d4f93b64d59698d2e28b.tar.bz2
upstream-9c6f4e54fbb93e2ca036d4f93b64d59698d2e28b.zip
Added hci_usb to kmod-bluetooth. Closes #316
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@3263 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--target/linux/aruba-2.6/config3
-rw-r--r--target/linux/brcm-2.6/config3
-rw-r--r--target/linux/generic-2.6/modules.mk1
-rw-r--r--target/linux/x86-2.6/config3
4 files changed, 7 insertions, 3 deletions
diff --git a/target/linux/aruba-2.6/config b/target/linux/aruba-2.6/config
index afda3fad85..f560d7e4b2 100644
--- a/target/linux/aruba-2.6/config
+++ b/target/linux/aruba-2.6/config
@@ -469,7 +469,8 @@ CONFIG_BT_HIDP=m
#
# Bluetooth device drivers
#
-# CONFIG_BT_HCIUSB is not set
+CONFIG_BT_HCIUSB=m
+CONFIG_BT_HCIUSB_SCO=y
CONFIG_BT_HCIUART=m
CONFIG_BT_HCIUART_H4=y
CONFIG_BT_HCIUART_BCSP=y
diff --git a/target/linux/brcm-2.6/config b/target/linux/brcm-2.6/config
index 303d8fd4f6..2cadc57898 100644
--- a/target/linux/brcm-2.6/config
+++ b/target/linux/brcm-2.6/config
@@ -562,7 +562,8 @@ CONFIG_BT_HIDP=m
#
# Bluetooth device drivers
#
-# CONFIG_BT_HCIUSB is not set
+CONFIG_BT_HCIUSB=m
+CONFIG_BT_HCIUSB_SCO=y
CONFIG_BT_HCIUART=m
CONFIG_BT_HCIUART_H4=y
CONFIG_BT_HCIUART_BCSP=y
diff --git a/target/linux/generic-2.6/modules.mk b/target/linux/generic-2.6/modules.mk
index 4e8d2e9689..37d7094c5c 100644
--- a/target/linux/generic-2.6/modules.mk
+++ b/target/linux/generic-2.6/modules.mk
@@ -342,6 +342,7 @@ $(eval $(call KMOD_template,BLUETOOTH,bluetooth,\
$(MODULES_DIR)/kernel/net/bluetooth/sco.ko \
$(MODULES_DIR)/kernel/net/bluetooth/rfcomm/rfcomm.ko \
$(MODULES_DIR)/kernel/drivers/bluetooth/hci_uart.ko \
+ $(MODULES_DIR)/kernel/drivers/bluetooth/hci_usb.ko \
,CONFIG_BT))
diff --git a/target/linux/x86-2.6/config b/target/linux/x86-2.6/config
index 5347e6b7d4..339972b670 100644
--- a/target/linux/x86-2.6/config
+++ b/target/linux/x86-2.6/config
@@ -592,7 +592,8 @@ CONFIG_BT_HIDP=m
#
# Bluetooth device drivers
#
-# CONFIG_BT_HCIUSB is not set
+CONFIG_BT_HCIUSB=m
+CONFIG_BT_HCIUSB_SCO=y
CONFIG_BT_HCIUART=m
CONFIG_BT_HCIUART_H4=y
CONFIG_BT_HCIUART_BCSP=y