aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-07-21 18:42:11 +0000
committerJohn Crispin <blogic@openwrt.org>2014-07-21 18:42:11 +0000
commit8d8ae568448e5b6677d7a87a1033eb34e3cf6043 (patch)
tree0bf9b16a7fa779b9ee9c90a2d333997240462e12
parentb31d078c16f97674cfd531b4a180f26af6a305a2 (diff)
downloadupstream-8d8ae568448e5b6677d7a87a1033eb34e3cf6043.tar.gz
upstream-8d8ae568448e5b6677d7a87a1033eb34e3cf6043.tar.bz2
upstream-8d8ae568448e5b6677d7a87a1033eb34e3cf6043.zip
target/linux/*/image/Makefile: eliminate more LINUX_DIR users
Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41792 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--include/kernel-defaults.mk1
-rw-r--r--target/linux/malta/image/Makefile2
-rw-r--r--target/linux/xburst/image/Makefile2
3 files changed, 3 insertions, 2 deletions
diff --git a/include/kernel-defaults.mk b/include/kernel-defaults.mk
index f1f5a81313..da06abd0a5 100644
--- a/include/kernel-defaults.mk
+++ b/include/kernel-defaults.mk
@@ -140,6 +140,7 @@ endif
define Kernel/CopyImage
$(KERNEL_CROSS)objcopy -O binary $(OBJCOPY_STRIP) -S $(LINUX_DIR)/vmlinux $(LINUX_KERNEL)$(1)
$(KERNEL_CROSS)objcopy $(OBJCOPY_STRIP) -S $(LINUX_DIR)/vmlinux $(KERNEL_BUILD_DIR)/vmlinux$(1).elf
+ $(CP) $(LINUX_DIR)/vmlinux $(KERNEL_BUILD_DIR)/vmlinux.debug
ifneq ($(subst ",,$(KERNELNAME)),)
#")
$(foreach k,$(filter-out dtbs,$(subst ",,$(KERNELNAME))),$(CP) $(LINUX_DIR)/arch/$(LINUX_KARCH)/boot/$(IMAGES_DIR)/$(k) $(KERNEL_BUILD_DIR)/$(k)$(1);)
diff --git a/target/linux/malta/image/Makefile b/target/linux/malta/image/Makefile
index c0e520fbee..db2637ad8f 100644
--- a/target/linux/malta/image/Makefile
+++ b/target/linux/malta/image/Makefile
@@ -21,7 +21,7 @@ endef
define MkuImage
mkimage -A mips -O linux -T kernel -a 0x80100000 -C $(1) $(2) \
- -e $(call get_kernel_entry,$(LINUX_DIR)/vmlinux) -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
+ -e $(call get_kernel_entry,$(KDIR)/vmlinux.debug) -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
-d $(3) $(4)
endef
diff --git a/target/linux/xburst/image/Makefile b/target/linux/xburst/image/Makefile
index 0de5560c96..49bb254164 100644
--- a/target/linux/xburst/image/Makefile
+++ b/target/linux/xburst/image/Makefile
@@ -27,7 +27,7 @@ endef
define MkImageGzip
gzip -9 -c $(1) > $(1).gz
mkimage -A mips -O linux -T kernel -a 0x80010000 -C gzip \
- -e $(call kernel_entry,$(LINUX_DIR)/vmlinux) -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
+ -e $(call kernel_entry,$(KDIR)/vmlinux.debug) -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
-d $(1).gz $(2)
endef