aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-10-28 15:15:05 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-10-28 15:15:05 +0000
commit7d9a6a4129900aec6013eb9ab37bc6901abf9569 (patch)
treea57bdd45a20fa34c470f9c10a09873c334911a01
parentff270220409f83ca4137ca2fb484735a766cd3ab (diff)
downloadupstream-7d9a6a4129900aec6013eb9ab37bc6901abf9569.tar.gz
upstream-7d9a6a4129900aec6013eb9ab37bc6901abf9569.tar.bz2
upstream-7d9a6a4129900aec6013eb9ab37bc6901abf9569.zip
u-boot: prefer mirror2.openwrt.org over ftp.denx.de - the denx ftp is slow and unreliable
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38559 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/boot/uboot-ar71xx/Makefile4
-rw-r--r--package/boot/uboot-envtools/Makefile5
-rw-r--r--package/boot/uboot-imx23/Makefile4
-rw-r--r--package/boot/uboot-imx6/Makefile4
-rw-r--r--package/boot/uboot-kirkwood/Makefile4
-rw-r--r--package/boot/uboot-lantiq/Makefile4
-rw-r--r--package/boot/uboot-omap35xx/Makefile4
-rw-r--r--package/boot/uboot-omap4/Makefile4
-rw-r--r--package/boot/uboot-xburst/Makefile4
9 files changed, 28 insertions, 9 deletions
diff --git a/package/boot/uboot-ar71xx/Makefile b/package/boot/uboot-ar71xx/Makefile
index ab692d579d..08439b231f 100644
--- a/package/boot/uboot-ar71xx/Makefile
+++ b/package/boot/uboot-ar71xx/Makefile
@@ -14,7 +14,9 @@ PKG_RELEASE:=1
PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=ftp://ftp.denx.de/pub/u-boot
+PKG_SOURCE_URL:= \
+ http://mirror2.openwrt.org/sources \
+ ftp://ftp.denx.de/pub/u-boot
PKG_MD5SUM:=
PKG_TARGETS:=bin
diff --git a/package/boot/uboot-envtools/Makefile b/package/boot/uboot-envtools/Makefile
index 6cea1e2b00..a0512284d5 100644
--- a/package/boot/uboot-envtools/Makefile
+++ b/package/boot/uboot-envtools/Makefile
@@ -13,7 +13,10 @@ PKG_VERSION:=2013.10
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_DISTNAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=ftp://ftp.denx.de/pub/u-boot
+PKG_SOURCE_URL:= \
+ http://mirror2.openwrt.org/sources \
+ ftp://ftp.denx.de/pub/u-boot
+
PKG_MD5SUM:=a076a044b64371edc52f7e562b13f6b2
PKG_BUILD_DIR:=$(BUILD_DIR)/u-boot-$(PKG_VERSION)
diff --git a/package/boot/uboot-imx23/Makefile b/package/boot/uboot-imx23/Makefile
index f41b23db16..10d0d8d3b0 100644
--- a/package/boot/uboot-imx23/Makefile
+++ b/package/boot/uboot-imx23/Makefile
@@ -13,7 +13,9 @@ PKG_RELEASE:=1
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=ftp://ftp.denx.de/pub/u-boot
+PKG_SOURCE_URL:= \
+ http://mirror2.openwrt.org/sources \
+ ftp://ftp.denx.de/pub/u-boot
PKG_MD5SUM:=8445162690052e6afd4b8f87af2bb557
include $(INCLUDE_DIR)/package.mk
diff --git a/package/boot/uboot-imx6/Makefile b/package/boot/uboot-imx6/Makefile
index c4112e6ce4..d2c6809960 100644
--- a/package/boot/uboot-imx6/Makefile
+++ b/package/boot/uboot-imx6/Makefile
@@ -13,7 +13,9 @@ PKG_RELEASE:=1
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=ftp://ftp.denx.de/pub/u-boot
+PKG_SOURCE_URL:= \
+ http://mirror2.openwrt.org/sources \
+ ftp://ftp.denx.de/pub/u-boot
PKG_MD5SUM:=8445162690052e6afd4b8f87af2bb557
include $(INCLUDE_DIR)/package.mk
diff --git a/package/boot/uboot-kirkwood/Makefile b/package/boot/uboot-kirkwood/Makefile
index dc66450480..375d115280 100644
--- a/package/boot/uboot-kirkwood/Makefile
+++ b/package/boot/uboot-kirkwood/Makefile
@@ -13,7 +13,9 @@ PKG_RELEASE:=1
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=ftp://ftp.denx.de/pub/u-boot
+PKG_SOURCE_URL:= \
+ http://mirror2.openwrt.org/sources \
+ ftp://ftp.denx.de/pub/u-boot
PKG_MD5SUM:=8655f63b1e5c4647295ac9ce44660be3
PKG_TARGETS:=bin
diff --git a/package/boot/uboot-lantiq/Makefile b/package/boot/uboot-lantiq/Makefile
index b3d9173190..b71b1e8578 100644
--- a/package/boot/uboot-lantiq/Makefile
+++ b/package/boot/uboot-lantiq/Makefile
@@ -13,7 +13,9 @@ PKG_RELEASE:=1
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=ftp://ftp.denx.de/pub/u-boot
+PKG_SOURCE_URL:= \
+ http://mirror2.openwrt.org/sources \
+ ftp://ftp.denx.de/pub/u-boot
PKG_MD5SUM:=e58a8a7f78972248190d83de0dc362ce
PKG_TARGETS:=bin
diff --git a/package/boot/uboot-omap35xx/Makefile b/package/boot/uboot-omap35xx/Makefile
index 928acc7d41..bb8a951537 100644
--- a/package/boot/uboot-omap35xx/Makefile
+++ b/package/boot/uboot-omap35xx/Makefile
@@ -14,7 +14,9 @@ PKG_RELEASE:=1
PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=ftp://ftp.denx.de/pub/u-boot
+PKG_SOURCE_URL:= \
+ http://mirror2.openwrt.org/sources \
+ ftp://ftp.denx.de/pub/u-boot
PKG_MD5SUM:=
PKG_TARGETS:=bin
diff --git a/package/boot/uboot-omap4/Makefile b/package/boot/uboot-omap4/Makefile
index d128e16bd1..d0830cfb85 100644
--- a/package/boot/uboot-omap4/Makefile
+++ b/package/boot/uboot-omap4/Makefile
@@ -14,7 +14,9 @@ PKG_RELEASE:=1
PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=ftp://ftp.denx.de/pub/u-boot
+PKG_SOURCE_URL:= \
+ http://mirror2.openwrt.org/sources \
+ ftp://ftp.denx.de/pub/u-boot
PKG_MD5SUM:=7f29b9f6da44d6e46e988e7561fd1d5f
PKG_TARGETS:=bin
diff --git a/package/boot/uboot-xburst/Makefile b/package/boot/uboot-xburst/Makefile
index f4c8ad9197..89802d0f40 100644
--- a/package/boot/uboot-xburst/Makefile
+++ b/package/boot/uboot-xburst/Makefile
@@ -14,7 +14,9 @@ PKG_RELEASE:=1
PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=ftp://ftp.denx.de/pub/u-boot
+PKG_SOURCE_URL:= \
+ http://mirror2.openwrt.org/sources \
+ ftp://ftp.denx.de/pub/u-boot
PKG_MD5SUM:=451c07271940016cec6f5ad8a155263b
PKG_TARGETS:=bin