aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2015-06-12 20:59:57 +0000
committerSteven Barth <steven@midlink.org>2015-06-12 20:59:57 +0000
commit698315c238b850dcb58c41d63392059d98472ad3 (patch)
tree597667ebc49683133a12083380ef8307a86e6c91
parent817cc83f79f08d1fb852309227b6a1d765c79a6c (diff)
downloadupstream-698315c238b850dcb58c41d63392059d98472ad3.tar.gz
upstream-698315c238b850dcb58c41d63392059d98472ad3.tar.bz2
upstream-698315c238b850dcb58c41d63392059d98472ad3.zip
openssl: bump to 1.0.2c
fixes CVE-2015-4000 CVE-2015-1788 CVE-2015-1789 CVE-2015-1790 CVE-2015-1792 CVE-2015-1791 Signed-off-by: Steven Barth <steven@midlink.org> git-svn-id: svn://svn.openwrt.org/openwrt/branches/barrier_breaker@45951 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/libs/openssl/Makefile4
-rw-r--r--package/libs/openssl/patches/110-optimize-for-size.patch2
-rw-r--r--package/libs/openssl/patches/150-no_engines.patch2
-rw-r--r--package/libs/openssl/patches/160-disable_doc_tests.patch6
-rw-r--r--package/libs/openssl/patches/190-remove_timestamp_check.patch6
-rw-r--r--package/libs/openssl/patches/200-parallel_build.patch16
-rw-r--r--package/libs/openssl/patches/220-fix-no-ec-build.patch14
7 files changed, 18 insertions, 32 deletions
diff --git a/package/libs/openssl/Makefile b/package/libs/openssl/Makefile
index b9767868e8..5770713786 100644
--- a/package/libs/openssl/Makefile
+++ b/package/libs/openssl/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=openssl
-PKG_VERSION:=1.0.2a
+PKG_VERSION:=1.0.2c
PKG_RELEASE:=0
PKG_USE_MIPS16:=0
@@ -18,7 +18,7 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.openssl.org/source/ \
ftp://ftp.funet.fi/pub/crypt/mirrors/ftp.openssl.org/source \
ftp://ftp.sunet.se/pub/security/tools/net/openssl/source/
-PKG_MD5SUM:=a06c547dac9044161a477211049f60ef
+PKG_MD5SUM:=8c8d81a9ae7005276e486702edbcd4b6
PKG_LICENSE:=SSLEAY OPENSSL
PKG_LICENSE_FILES:=LICENSE
diff --git a/package/libs/openssl/patches/110-optimize-for-size.patch b/package/libs/openssl/patches/110-optimize-for-size.patch
index c9443221f8..0a0e59a3bf 100644
--- a/package/libs/openssl/patches/110-optimize-for-size.patch
+++ b/package/libs/openssl/patches/110-optimize-for-size.patch
@@ -1,6 +1,6 @@
--- a/Configure
+++ b/Configure
-@@ -443,6 +443,12 @@ my %table=(
+@@ -460,6 +460,12 @@ my %table=(
"linux-alpha-ccc","ccc:-fast -readonly_strings -DL_ENDIAN::-D_REENTRANT:::SIXTY_FOUR_BIT_LONG RC4_CHUNK DES_INT DES_PTR DES_RISC1 DES_UNROLL:${alpha_asm}",
"linux-alpha+bwx-ccc","ccc:-fast -readonly_strings -DL_ENDIAN::-D_REENTRANT:::SIXTY_FOUR_BIT_LONG RC4_CHAR RC4_CHUNK DES_INT DES_PTR DES_RISC1 DES_UNROLL:${alpha_asm}",
diff --git a/package/libs/openssl/patches/150-no_engines.patch b/package/libs/openssl/patches/150-no_engines.patch
index df3f8662e6..e0c80e4c88 100644
--- a/package/libs/openssl/patches/150-no_engines.patch
+++ b/package/libs/openssl/patches/150-no_engines.patch
@@ -1,6 +1,6 @@
--- a/Configure
+++ b/Configure
-@@ -2076,6 +2076,11 @@ EOF
+@@ -2103,6 +2103,11 @@ EOF
close(OUT);
}
diff --git a/package/libs/openssl/patches/160-disable_doc_tests.patch b/package/libs/openssl/patches/160-disable_doc_tests.patch
index e31ffa5815..afd50650e7 100644
--- a/package/libs/openssl/patches/160-disable_doc_tests.patch
+++ b/package/libs/openssl/patches/160-disable_doc_tests.patch
@@ -34,9 +34,9 @@
-build_all: build_libs build_apps build_tests build_tools
+build_all: build_libs build_apps build_tools
- build_libs: build_crypto build_ssl build_engines
+ build_libs: build_libcrypto build_libssl openssl.pc
-@@ -538,7 +538,7 @@ dist:
+@@ -528,7 +528,7 @@ dist:
dist_pem_h:
(cd crypto/pem; $(MAKE) -e $(BUILDENV) pem.h; $(MAKE) clean)
@@ -47,7 +47,7 @@
@$(PERL) $(TOP)/util/mkdir-p.pl $(INSTALL_PREFIX)$(INSTALLTOP)/bin \
--- a/Makefile.org
+++ b/Makefile.org
-@@ -536,7 +536,7 @@ dist:
+@@ -526,7 +526,7 @@ dist:
dist_pem_h:
(cd crypto/pem; $(MAKE) -e $(BUILDENV) pem.h; $(MAKE) clean)
diff --git a/package/libs/openssl/patches/190-remove_timestamp_check.patch b/package/libs/openssl/patches/190-remove_timestamp_check.patch
index 86b17d0340..8a832a4415 100644
--- a/package/libs/openssl/patches/190-remove_timestamp_check.patch
+++ b/package/libs/openssl/patches/190-remove_timestamp_check.patch
@@ -4,12 +4,12 @@
EXHEADER= e_os2.h
HEADER= e_os.h
--all: Makefile build_all openssl.pc libssl.pc libcrypto.pc
-+all: build_all openssl.pc libssl.pc libcrypto.pc
+-all: Makefile build_all
++all: build_all
# as we stick to -e, CLEARENV ensures that local variables in lower
# Makefiles remain local and variable. $${VAR+VAR} is tribute to Korn
-@@ -395,11 +395,6 @@ openssl.pc: Makefile
+@@ -398,11 +398,6 @@ openssl.pc: Makefile
echo 'Version: '$(VERSION); \
echo 'Requires: libssl libcrypto' ) > openssl.pc
diff --git a/package/libs/openssl/patches/200-parallel_build.patch b/package/libs/openssl/patches/200-parallel_build.patch
index c2eeb387f5..ff63e02982 100644
--- a/package/libs/openssl/patches/200-parallel_build.patch
+++ b/package/libs/openssl/patches/200-parallel_build.patch
@@ -1,7 +1,7 @@
--- a/Makefile.org
+++ b/Makefile.org
-@@ -274,17 +274,17 @@ build_all: build_libs build_apps build_t
- build_libs: build_crypto build_ssl build_engines
+@@ -277,17 +277,17 @@ build_libcrypto: build_crypto build_engi
+ build_libssl: build_ssl libssl.pc
build_crypto:
- @dir=crypto; target=all; $(BUILD_ONE_CMD)
@@ -29,8 +29,8 @@
all_testapps: build_libs build_testapps
build_testapps:
-@@ -453,7 +453,7 @@ report:
- @$(PERL) util/selftest.pl
+@@ -459,7 +459,7 @@ update: errors stacks util/libeay.num ut
+ @set -e; target=update; $(RECURSIVE_BUILD_CMD)
depend:
- @set -e; target=depend; $(RECURSIVE_BUILD_CMD)
@@ -38,7 +38,7 @@
lint:
@set -e; target=lint; $(RECURSIVE_BUILD_CMD)
-@@ -531,9 +531,9 @@ dist:
+@@ -521,9 +521,9 @@ dist:
dist_pem_h:
(cd crypto/pem; $(MAKE) -e $(BUILDENV) pem.h; $(MAKE) clean)
@@ -50,7 +50,7 @@
@$(PERL) $(TOP)/util/mkdir-p.pl $(INSTALL_PREFIX)$(INSTALLTOP)/bin \
$(INSTALL_PREFIX)$(INSTALLTOP)/$(LIBDIR) \
$(INSTALL_PREFIX)$(INSTALLTOP)/$(LIBDIR)/engines \
-@@ -542,12 +542,19 @@ install_sw:
+@@ -532,12 +532,19 @@ install_sw:
$(INSTALL_PREFIX)$(OPENSSLDIR)/misc \
$(INSTALL_PREFIX)$(OPENSSLDIR)/certs \
$(INSTALL_PREFIX)$(OPENSSLDIR)/private
@@ -71,7 +71,7 @@
@set -e; liblist="$(LIBS)"; for i in $$liblist ;\
do \
if [ -f "$$i" ]; then \
-@@ -631,12 +638,7 @@ install_html_docs:
+@@ -621,12 +628,7 @@ install_html_docs:
done; \
done
@@ -178,7 +178,7 @@
apps:
@(cd ..; $(MAKE) DIRS=apps all)
-@@ -529,7 +529,7 @@ $(CONSTTIMETEST)$(EXE_EXT): $(CONSTTIMET
+@@ -530,7 +530,7 @@ $(CONSTTIMETEST)$(EXE_EXT): $(CONSTTIMET
# fi
dummytest$(EXE_EXT): dummytest.o $(DLIBCRYPTO)
diff --git a/package/libs/openssl/patches/220-fix-no-ec-build.patch b/package/libs/openssl/patches/220-fix-no-ec-build.patch
index 44ec50eae4..e69de29bb2 100644
--- a/package/libs/openssl/patches/220-fix-no-ec-build.patch
+++ b/package/libs/openssl/patches/220-fix-no-ec-build.patch
@@ -1,14 +0,0 @@
---- a/ssl/t1_lib.c
-+++ b/ssl/t1_lib.c
-@@ -113,9 +113,11 @@
- #include <openssl/objects.h>
- #include <openssl/evp.h>
- #include <openssl/hmac.h>
-+#ifndef OPENSSL_NO_EC
- #ifdef OPENSSL_NO_EC2M
- # include <openssl/ec.h>
- #endif
-+#endif
- #include <openssl/ocsp.h>
- #include <openssl/rand.h>
- #include "ssl_locl.h"