aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-04-20 18:56:57 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-04-20 18:56:57 +0000
commit6937a43f9be9aa0f730112203fa5ebe63db67964 (patch)
tree4ec0bbb4e5f6fd27978bfb982f85d22c5140819d
parent33334cc3b611c4895c0e81b404e3ccd01a42b408 (diff)
downloadupstream-6937a43f9be9aa0f730112203fa5ebe63db67964.tar.gz
upstream-6937a43f9be9aa0f730112203fa5ebe63db67964.tar.bz2
upstream-6937a43f9be9aa0f730112203fa5ebe63db67964.zip
move pkg config stuff to per-target exports to prevent interference with host builds
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15299 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--include/host-build.mk2
-rw-r--r--include/package-defaults.mk3
-rw-r--r--include/package.mk4
3 files changed, 6 insertions, 3 deletions
diff --git a/include/host-build.mk b/include/host-build.mk
index ffba12b51d..1a794846bb 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -115,6 +115,8 @@ ifndef DUMP
$(call Host/Prepare)
touch $$@
+ $(HOST_STAMP_CONFIGURED) : export PKG_CONFIG_PATH=$$(STAGING_DIR_HOST)/lib/pkgconfig
+ $(HOST_STAMP_CONFIGURED) : export PKG_CONFIG_LIBDIR=$$(STAGING_DIR_HOST)/lib/pkgconfig
$(HOST_STAMP_CONFIGURED): $(HOST_STAMP_PREPARED)
$(call Host/Configure)
touch $$@
diff --git a/include/package-defaults.mk b/include/package-defaults.mk
index e375722af9..1eae7ea246 100644
--- a/include/package-defaults.mk
+++ b/include/package-defaults.mk
@@ -43,9 +43,6 @@ ifneq ($(strip $(PKG_UNPACK)),)
endef
endif
-export PKG_CONFIG_PATH=$(STAGING_DIR)/usr/lib/pkgconfig:$(STAGING_DIR_HOST)/usr/lib/pkgconfig
-export PKG_CONFIG_LIBDIR=$(STAGING_DIR)/usr/lib/pkgconfig
-
CONFIGURE_PREFIX:=/usr
CONFIGURE_ARGS = \
--target=$(GNU_TARGET_NAME) \
diff --git a/include/package.mk b/include/package.mk
index 719468c253..2049e2f316 100644
--- a/include/package.mk
+++ b/include/package.mk
@@ -78,6 +78,8 @@ define Build/DefaultTargets
$(STAMP_CONFIGURED) : export PATH=$$(TARGET_PATH_PKG)
$(STAMP_CONFIGURED) : export CONFIG_SITE:=$$(CONFIG_SITE)
+ $(STAMP_CONFIGURED) : export PKG_CONFIG_PATH=$$(STAGING_DIR)/usr/lib/pkgconfig
+ $(STAMP_CONFIGURED) : export PKG_CONFIG_LIBDIR=$$(STAGING_DIR)/usr/lib/pkgconfig
$(STAMP_CONFIGURED): $(STAMP_PREPARED)
$(foreach hook,$(Hooks/Configure/Pre),$(call $(hook))$(sep))
$(Build/Configure)
@@ -86,6 +88,8 @@ define Build/DefaultTargets
$(STAMP_BUILT) : export PATH=$$(TARGET_PATH_PKG)
$(STAMP_BUILT) : export CONFIG_SITE:=$$(CONFIG_SITE)
+ $(STAMP_BUILT) : export PKG_CONFIG_PATH=$$(STAGING_DIR)/usr/lib/pkgconfig:$$(STAGING_DIR_HOST)/usr/lib/pkgconfig
+ $(STAMP_BUILT) : export PKG_CONFIG_LIBDIR=$$(STAGING_DIR)/usr/lib/pkgconfig
$(STAMP_BUILT): $(STAMP_CONFIGURED)
$(foreach hook,$(Hooks/Compile/Pre),$(call $(hook))$(sep))
$(Build/Compile)