aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorZoltan HERPAI <wigyori@uid0.hu>2013-07-08 08:45:03 +0000
committerZoltan HERPAI <wigyori@uid0.hu>2013-07-08 08:45:03 +0000
commit5bf3d3a7d96f69a3c3fcefa3ecaa3a032db509e8 (patch)
tree155f136f64db44dadf1034e82bd8e21de288a649
parent058f768c198027a431c84f9858f9a67aabbcfda9 (diff)
downloadupstream-5bf3d3a7d96f69a3c3fcefa3ecaa3a032db509e8.tar.gz
upstream-5bf3d3a7d96f69a3c3fcefa3ecaa3a032db509e8.tar.bz2
upstream-5bf3d3a7d96f69a3c3fcefa3ecaa3a032db509e8.zip
[tools] add bc as required by kernels 3.9+
- bc is required by the kernel to compute timeconsts files - fixes #13767. Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37197 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--tools/Makefile2
-rw-r--r--tools/bc/Makefile18
2 files changed, 19 insertions, 1 deletions
diff --git a/tools/Makefile b/tools/Makefile
index 61b53a9a55..a1e7c18bc2 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -16,7 +16,7 @@ endif
tools-y += m4 libtool autoconf automake flex bison pkg-config sed mklibs
tools-y += sstrip ipkg-utils genext2fs e2fsprogs mtd-utils mkimage
tools-y += firmware-utils patch-image patch quilt yaffs2 flock padjffs2
-tools-y += mm-macros xorg-macros xfce-macros missing-macros xz cmake scons
+tools-y += mm-macros xorg-macros xfce-macros missing-macros xz cmake scons bc
tools-$(CONFIG_TARGET_orion_generic) += wrt350nv2-builder upslug2
tools-$(CONFIG_powerpc) += upx
tools-$(CONFIG_TARGET_x86) += qemu
diff --git a/tools/bc/Makefile b/tools/bc/Makefile
new file mode 100644
index 0000000000..87c7e58006
--- /dev/null
+++ b/tools/bc/Makefile
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=bc
+PKG_VERSION:=1.06.95
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://alpha.gnu.org/gnu/bc
+PKG_MD5SUM:=5126a721b73f97d715bb72c13c889035
+
+include $(INCLUDE_DIR)/host-build.mk
+
+$(eval $(call HostBuild))