aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-11-03 08:32:50 +0000
committerJohn Crispin <blogic@openwrt.org>2014-11-03 08:32:50 +0000
commit518b8fee7d8a23b1bf2295e11cb52f04fc953d64 (patch)
tree9c3cd0dbc33697afbe207be0b5edda5e7fb85a26
parent739fda67e214789ae77d49b373307a57a980a554 (diff)
downloadupstream-518b8fee7d8a23b1bf2295e11cb52f04fc953d64.tar.gz
upstream-518b8fee7d8a23b1bf2295e11cb52f04fc953d64.tar.bz2
upstream-518b8fee7d8a23b1bf2295e11cb52f04fc953d64.zip
BB: lantiq: vr9: - fix vmmc build
(required not-distributable firmware blob - dump it by yourself from original firmware) Signed-off-by: Eddi De Pieri <eddi@depieri.net> git-svn-id: svn://svn.openwrt.org/openwrt/branches/barrier_breaker@43161 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/kernel/lantiq/ltq-vmmc/Config.in8
-rw-r--r--package/kernel/lantiq/ltq-vmmc/Makefile15
2 files changed, 18 insertions, 5 deletions
diff --git a/package/kernel/lantiq/ltq-vmmc/Config.in b/package/kernel/lantiq/ltq-vmmc/Config.in
index 89e1bc5cba..b8ab6a4be3 100644
--- a/package/kernel/lantiq/ltq-vmmc/Config.in
+++ b/package/kernel/lantiq/ltq-vmmc/Config.in
@@ -13,10 +13,10 @@ choice
# bool "AR9 family"
# depends on TARGET_lantiq_ar9
-# config VOICE_CPE_VMMC_WITH_DEVICE_VR9
-# bool "VR9 family"
-# depends on TARGET_lantiq_vr9
-#
+ config VOICE_CPE_VMMC_WITH_DEVICE_VR9
+ bool "VR9 family"
+ depends on TARGET_lantiq_xrx200
+
config VOICE_VMMC_WITH_DEVICE_FALCON
bool "FALC-ON"
depends on (TARGET_lantiq_falcon||TARGET_lantiq_falcon_stable)
diff --git a/package/kernel/lantiq/ltq-vmmc/Makefile b/package/kernel/lantiq/ltq-vmmc/Makefile
index d25f3e14b2..eb758648b0 100644
--- a/package/kernel/lantiq/ltq-vmmc/Makefile
+++ b/package/kernel/lantiq/ltq-vmmc/Makefile
@@ -120,7 +120,19 @@ endif
ifeq ($(CONFIG_VOICE_CPE_VMMC_WITH_DEVICE_VR9),y)
CONFIGURE_ARGS += --with-device=VR9
- # TODO: add fw/coef
+ FW_TARGET:=voice_ar9_firmware.bin
+ FW_SOURCE:=voip_R2.3.1.7.0-enc.bin
+ FW_FILE=fw_voip_vr9-2.3.1.7.0.tar.gz
+ FW_MD5SUM:=635edd1e2af8ca249cc7e80b779f3270
+ FW_DOWNLOAD:=1
+ COEF_SRC:=ETSI_3_10.BIN
+ COEF_TARGET:=vr9_bbd_fxs.bin
+ COEF_FILE:=coef_voip_vr9-0.9.3.tar.gz
+ COEF_MD5SUM:=66fa5c6a4110726b1f8658359b8008e6
+ COEF_DOWNLOAD:=1
+
+ COEF_SRC_FXO:=FXO_ETSI_0_0.BIN
+ COEF_TARGET_FXO:=vr9_bbd.bin
endif
define Download/firmware
@@ -163,6 +175,7 @@ define KernelPackage/ltq-vmmc/install
$(CP) $(PKG_BUILD_DIR)/firmware/$(FW_SOURCE) $(1)/$(FW_DIR)/$(FW_TARGET)
ln -s /$(FW_DIR)/$(FW_TARGET) $(1)/$(FW_DIR)/$(FW_TARGET_GENERIC)
$(CP) $(PKG_BUILD_DIR)/coef/$(COEF_SRC) $(1)/$(FW_DIR)/$(COEF_TARGET)
+ $(CP) $(PKG_BUILD_DIR)/coef/$(COEF_SRC_FXO) $(1)/$(FW_DIR)/$(COEF_TARGET_FXO)
ln -s /$(FW_DIR)/$(COEF_TARGET) $(1)/$(FW_DIR)/$(COEF_TARGET_GENERIC)
endef