aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-02-26 21:29:57 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-02-26 21:29:57 +0000
commit2d02cbbdd536cd3e970aed5e8c6353ebaf8b2a5d (patch)
tree7930d595b61726b71814c27e08966dab9c93f0c4
parenta4de2166a63cd9f8c78f6d4c39068a1a9a613b0f (diff)
downloadupstream-2d02cbbdd536cd3e970aed5e8c6353ebaf8b2a5d.tar.gz
upstream-2d02cbbdd536cd3e970aed5e8c6353ebaf8b2a5d.tar.bz2
upstream-2d02cbbdd536cd3e970aed5e8c6353ebaf8b2a5d.zip
BB: ubox: fix segmentation fault in insmod
Fix segfault in kmodloader insmod mode due to uninitialized module directory list. Apply the required fix as patch for now since we don't have the ulog infrastructure in BB (yet) required for the git head of ubox. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/branches/barrier_breaker@44550 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/system/ubox/Makefile2
-rw-r--r--package/system/ubox/patches/100-insmod-segfault.patch12
2 files changed, 13 insertions, 1 deletions
diff --git a/package/system/ubox/Makefile b/package/system/ubox/Makefile
index 471afd6dc0..2d7ed29741 100644
--- a/package/system/ubox/Makefile
+++ b/package/system/ubox/Makefile
@@ -1,7 +1,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=ubox
-PKG_VERSION:=2015-02-25
+PKG_VERSION:=2015-02-25.1
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git
diff --git a/package/system/ubox/patches/100-insmod-segfault.patch b/package/system/ubox/patches/100-insmod-segfault.patch
new file mode 100644
index 0000000000..df010d1a66
--- /dev/null
+++ b/package/system/ubox/patches/100-insmod-segfault.patch
@@ -0,0 +1,12 @@
+--- a/kmodloader.c
++++ b/kmodloader.c
+@@ -605,6 +605,9 @@ static int main_insmod(int argc, char **
+ cur += sprintf(cur, "%s", argv[i]);
+ }
+
++ if (init_module_folders())
++ return -1;
++
+ if (get_module_path(argv[1])) {
+ name = argv[1];
+ } else if (!get_module_path(name)) {