aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-09-01 13:21:44 +0000
committerJohn Crispin <blogic@openwrt.org>2014-09-01 13:21:44 +0000
commit2b95b519db10c818c04081ff924a8f330a49eb71 (patch)
tree6aa6993cd29cb6453b7b54cffcdc43def5086b24
parentd72a6f145efd8c7a43f24a26e14d17353f5ee4da (diff)
downloadupstream-2b95b519db10c818c04081ff924a8f330a49eb71.tar.gz
upstream-2b95b519db10c818c04081ff924a8f330a49eb71.tar.bz2
upstream-2b95b519db10c818c04081ff924a8f330a49eb71.zip
valgrind: fix build failure on uml
Signed-off-by: Nicolas Thill <nico@openwrt.org> Backport of r42229 git-svn-id: svn://svn.openwrt.org/openwrt/branches/barrier_breaker@42372 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/devel/valgrind/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/devel/valgrind/Makefile b/package/devel/valgrind/Makefile
index a55fb40d80..0074ad49b0 100644
--- a/package/devel/valgrind/Makefile
+++ b/package/devel/valgrind/Makefile
@@ -77,7 +77,7 @@ define Package/valgrind/description
to speed up and reduce memory use of your programs.
endef
-CPU := $(patsubst x86_64,amd64,$(patsubst x86,i386,$(LINUX_KARCH)))
+CPU := $(patsubst x86_64,amd64,$(patsubst x86,i386,$(patsubst um,$(ARCH),$(LINUX_KARCH))))
CONFIGURE_VARS += \
UNAME_R=$(LINUX_VERSION)