aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-07-04 12:56:21 +0000
committerJonas Gorski <jogo@openwrt.org>2015-07-04 12:56:21 +0000
commit252afa401f6ec40e73c3c880595a4fe20ade1e28 (patch)
treee934125eaf8aea2a0e3d4da555391b9d5cba240b
parent3ba9a533100d6883043e759d6978db0b75f61bc1 (diff)
downloadupstream-252afa401f6ec40e73c3c880595a4fe20ade1e28.tar.gz
upstream-252afa401f6ec40e73c3c880595a4fe20ade1e28.tar.bz2
upstream-252afa401f6ec40e73c3c880595a4fe20ade1e28.zip
BB: kernel: kmod-scsi-core: fix load on install
sd_mod depends on scsi_mod, but due to it being an AutoLoad and not AutoProbe module, it was not loading when installing the package, causing unknown symbol errors for sd_mod and anything depending on it. Closes #14927, #18293, #19351. Backport of r46176. Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/branches/barrier_breaker@46178 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/kernel/linux/modules/block.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/kernel/linux/modules/block.mk b/package/kernel/linux/modules/block.mk
index 8a84aa4e22..8c29e01ad1 100644
--- a/package/kernel/linux/modules/block.mk
+++ b/package/kernel/linux/modules/block.mk
@@ -565,9 +565,9 @@ define KernelPackage/scsi-core
CONFIG_SCSI \
CONFIG_BLK_DEV_SD
FILES:= \
- $(if $(findstring y,$(CONFIG_SCSI)),,$(LINUX_DIR)/drivers/scsi/scsi_mod.ko) \
+ $(LINUX_DIR)/drivers/scsi/scsi_mod.ko \
$(LINUX_DIR)/drivers/scsi/sd_mod.ko
- AUTOLOAD:=$(call AutoLoad,40,sd_mod,1)
+ AUTOLOAD:=$(call AutoLoad,40,scsi_mod sd_mod,1)
endef
$(eval $(call KernelPackage,scsi-core))