aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-02-13 03:26:10 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-02-13 03:26:10 +0000
commitff1a0f6304d26acbc15bace4c19d561758403af6 (patch)
tree9b4f401780e80c9c7f1544829f97a986e5f7423f
parentb6c9d7f86d673a858bc7a40638be8a02b724e3de (diff)
downloadupstream-ff1a0f6304d26acbc15bace4c19d561758403af6.tar.gz
upstream-ff1a0f6304d26acbc15bace4c19d561758403af6.tar.bz2
upstream-ff1a0f6304d26acbc15bace4c19d561758403af6.zip
remove the shared object stubs of libnsl and libresolv - let the compiler use the static variants instead
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@25511 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/base-files/Makefile2
-rw-r--r--toolchain/uClibc/Makefile3
2 files changed, 4 insertions, 1 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 90a65d61de..82bf51a2bd 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -443,7 +443,7 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
$(TOOLCHAIN_DIR)/lib/libc.so.* \
$(TOOLCHAIN_DIR)/lib/libuClibc-$(LIBC_SO_VERSION).so \
$(1)/lib/
- for file in libcrypt libdl libm libnsl libresolv libutil; do \
+ for file in libcrypt libdl libm libutil; do \
$(CP) \
$(TOOLCHAIN_DIR)/lib/$$$$file.so.* \
$(TOOLCHAIN_DIR)/lib/$$$$file-$(LIBC_SO_VERSION).so \
diff --git a/toolchain/uClibc/Makefile b/toolchain/uClibc/Makefile
index f522903563..681341903e 100644
--- a/toolchain/uClibc/Makefile
+++ b/toolchain/uClibc/Makefile
@@ -128,6 +128,9 @@ define Host/Compile
done \
done \
)
+ rm -f \
+ $(TOOLCHAIN_DIR)/lib/libresolv*.so* \
+ $(TOOLCHAIN_DIR)/lib/libnsl*.so*
endef
define Host/Install