aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-04-30 19:38:58 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-04-30 19:38:58 +0000
commitfe7233958cbc429cb054726d2d313cb5a6615866 (patch)
treeb129d70bdd83309ad0fa953e6f2fd28b5790cfc9
parent8bebfa01a3a816171d4091ee3aaf12ec1338bed9 (diff)
downloadupstream-fe7233958cbc429cb054726d2d313cb5a6615866.tar.gz
upstream-fe7233958cbc429cb054726d2d313cb5a6615866.tar.bz2
upstream-fe7233958cbc429cb054726d2d313cb5a6615866.zip
opkg: work around the same broken array overrun check in gcc 4.4 as in gcc 4.3
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15522 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/opkg/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/opkg/Makefile b/package/opkg/Makefile
index 8a06ec0726..8b1961985e 100644
--- a/package/opkg/Makefile
+++ b/package/opkg/Makefile
@@ -40,7 +40,7 @@ define Package/opkg/conffiles
/etc/opkg.conf
endef
-TARGET_CFLAGS += $(FPIC) $(if $(CONFIG_GCC_VERSION_4_3),-Wno-array-bounds)
+TARGET_CFLAGS += $(FPIC) $(if $(CONFIG_GCC_VERSION_4_3)$(CONFIG_GCC_VERSION_4_4),-Wno-array-bounds)
EXTRA_CFLAGS += $(TARGET_CPPFLAGS)
EXTRA_LDFLAGS += $(TARGET_LDFLAGS) -Wl,-rpath-link,$(STAGING_DIR)/usr/lib