aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2011-01-27 13:24:38 +0000
committerImre Kaloz <kaloz@openwrt.org>2011-01-27 13:24:38 +0000
commitf9060eb6b073cfcee11ff27e92617367f98427ac (patch)
treefcc73428d82bb716da86687b6d90568cf0332b17
parent96b1ff4aaff8b7b3a6dd0bfcb8fc359f8c3fac85 (diff)
downloadupstream-f9060eb6b073cfcee11ff27e92617367f98427ac.tar.gz
upstream-f9060eb6b073cfcee11ff27e92617367f98427ac.tar.bz2
upstream-f9060eb6b073cfcee11ff27e92617367f98427ac.zip
[toolchain]: get rid of gcc 4.1.2 and 4.2.4 support
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@25144 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/uci/Makefile5
-rw-r--r--toolchain/gcc/Config.in8
-rw-r--r--toolchain/gcc/Config.version8
3 files changed, 1 insertions, 20 deletions
diff --git a/package/uci/Makefile b/package/uci/Makefile
index 78b3fa8e3a..bd46864bc2 100644
--- a/package/uci/Makefile
+++ b/package/uci/Makefile
@@ -65,11 +65,6 @@ UCI_MAKEOPTS = \
FPIC="$(FPIC)" \
OS="Linux"
-# work around a nasty gcc bug
-ifneq ($(CONFIG_GCC_VERSION_4_2_4),)
- UCI_MAKEOPTS += WOPTS=""
-endif
-
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) $(UCI_MAKEOPTS)
$(MAKE) -C $(PKG_BUILD_DIR)/lua $(UCI_MAKEOPTS)
diff --git a/toolchain/gcc/Config.in b/toolchain/gcc/Config.in
index 01b8f60044..cd4f3e25e9 100644
--- a/toolchain/gcc/Config.in
+++ b/toolchain/gcc/Config.in
@@ -12,12 +12,6 @@ choice
help
Select the version of gcc you wish to use.
- config GCC_VERSION_4_1_2
- bool "gcc 4.1.2"
-
- config GCC_VERSION_4_2_4
- bool "gcc 4.2.4"
-
config GCC_VERSION_4_3_5
bool "gcc 4.3.5"
@@ -84,7 +78,7 @@ config INSTALL_LIBSTDCPP
config INSTALL_LIBGCJ
bool
- depends on !(GCC_VERSION_4_1||GCC_VERSION_4_2)
+ depends on !GCC_VERSION_4_2
prompt "Build/install java compiler and GNU classpath ?" if TOOLCHAINOPTS
default n
help
diff --git a/toolchain/gcc/Config.version b/toolchain/gcc/Config.version
index a5a1ea63b5..a39c0e88a9 100644
--- a/toolchain/gcc/Config.version
+++ b/toolchain/gcc/Config.version
@@ -1,7 +1,5 @@
config GCC_VERSION
string
- default "4.1.2" if GCC_VERSION_4_1_2
- default "4.2.4" if GCC_VERSION_4_2_4
default "4.3.3+cs" if GCC_VERSION_4_3_3_CS
default "4.3.5" if GCC_VERSION_4_3_5
default "4.4.1+cs" if GCC_VERSION_4_4_1_CS
@@ -13,19 +11,13 @@ config GCC_VERSION
config GCC_VERSION_4
bool
- default y if GCC_VERSION_4_1
default y if GCC_VERSION_4_2
default y if GCC_VERSION_4_3
default y if GCC_VERSION_4_4
default y if GCC_VERSION_4_5
-config GCC_VERSION_4_1
- bool
- default y if GCC_VERSION_4_1_2
-
config GCC_VERSION_4_2
bool
- default y if GCC_VERSION_4_2_4
default y if GCC_VERSION_LLVM
config GCC_VERSION_4_3