aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2009-05-06 23:52:46 +0000
committerFlorian Fainelli <florian@openwrt.org>2009-05-06 23:52:46 +0000
commitf77c0a242a8ed81dd2b77272838c64c38e494d50 (patch)
tree06a8cff02e3492ab292b7ca6e22f51dcdf2013ad
parent6652efabcf8372f20bc47bf6ae9a293b8c0a6268 (diff)
downloadupstream-f77c0a242a8ed81dd2b77272838c64c38e494d50.tar.gz
upstream-f77c0a242a8ed81dd2b77272838c64c38e494d50.tar.bz2
upstream-f77c0a242a8ed81dd2b77272838c64c38e494d50.zip
[package] package the rtc-core and rtc-m48t86 driver
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15647 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/kernel/modules/other.mk34
1 files changed, 34 insertions, 0 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index 3b41e9d32d..5d156cc58d 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -878,3 +878,37 @@ endef
$(eval $(call KernelPackage,rfkill))
+
+define KernelPackage/rtc-core
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Kernel support for RTC devices
+ DEPENDS:=@LINUX_2_6
+ KCONFIG:= \
+ CONFIG_RTC_CLASS \
+ CONFIG_RTC_HCTOSYS=y \
+ CONFIG_RTC_HCTOSYS_DEVICE=rtc0
+ FILES:= \
+ $(LINUX_DIR)/drivers/rtc/rtc-core.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,30,rtc-core)
+endef
+
+define KernelPackage/rtc-core/description
+ Kernel module for the RTC devices.
+endef
+
+$(eval $(call KernelPackage,rtc-core))
+
+define KernelPackage/rtc-m48t86
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=RTC M48T86 / Dallas DS12887
+ DEPENDS:=+kmod-rtc-core
+ KCONFIG:=CONFIG_RTC_DRV_M48T86
+ FILES:=$(LINUX_DIR)/drivers/rtc/rtc-m48t86.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,31,rtc-m48t86)
+endef
+
+define KernelPackage/rtc-m48t86/description
+ Kernel support for the RTC device M48T86 / Dallas DS12887
+endef
+
+$(eval $(call KernelPackage,rtc-m48t86))