aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2008-04-26 10:14:55 +0000
committerImre Kaloz <kaloz@openwrt.org>2008-04-26 10:14:55 +0000
commitf0f8bb0ae9377091be6e88e0f7457a3a3fbf470d (patch)
treea26fda8d4da0ee38d86ddc8788f61cb4a588aaee
parentf87edf704fff1ac43584c8e4e51168c44b8ab47d (diff)
downloadupstream-f0f8bb0ae9377091be6e88e0f7457a3a3fbf470d.tar.gz
upstream-f0f8bb0ae9377091be6e88e0f7457a3a3fbf470d.tar.bz2
upstream-f0f8bb0ae9377091be6e88e0f7457a3a3fbf470d.zip
PXA can use EABI, too
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10949 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--target/linux/pxa/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/target/linux/pxa/Makefile b/target/linux/pxa/Makefile
index 7bf4c38f1c..d4d326f9a6 100644
--- a/target/linux/pxa/Makefile
+++ b/target/linux/pxa/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
ARCH:=arm
BOARD:=pxa
-BOARDNAME:=PXA
+BOARDNAME:=Marvell/Intel PXA2xx
FEATURES:=jffs2 broken
LINUX_VERSION:=2.6.21.7
@@ -16,7 +16,13 @@ LINUX_VERSION:=2.6.21.7
include $(INCLUDE_DIR)/target.mk
define Target/Description
- Stub for boards based on intel PXA
+ Build images for PAX2xx systems, eg. Gumstix.
+endef
+
+define Kernel/Configure
+ $(call Kernel/Configure/Default)
+ $(SED) 's,.*CONFIG_AEABI.*,$(if $(CONFIG_EABI_SUPPORT),CONFIG_AEABI=y,# CONFIG_AEABI is not set),' $(LINUX_DIR)/.config
+ $(if $(CONFIG_EABI_SUPPORT),echo '# CONFIG_OABI_COMPAT is not set' >> $(LINUX_DIR)/.config)
endef
$(eval $(call BuildTarget))