aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-12-19 18:10:41 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-12-19 18:10:41 +0000
commitefe27b1e6992f3d6cad1623223a1e30ecbfb313c (patch)
tree954f6dfe02312a44c89bbbf5964643dc6f8e5486
parentc97b8e0db1299c7679493ee9db26c1f21376f70a (diff)
downloadupstream-efe27b1e6992f3d6cad1623223a1e30ecbfb313c.tar.gz
upstream-efe27b1e6992f3d6cad1623223a1e30ecbfb313c.tar.bz2
upstream-efe27b1e6992f3d6cad1623223a1e30ecbfb313c.zip
ar71xx: fix WNDR3700 firmware images
WNDR3700's U-Boot loads the kernel from a squashfs image, and it does not support squashfs 4.0. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18851 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--target/linux/ar71xx/image/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 92f698a35c..b6012b21b8 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -241,9 +241,9 @@ define Image/Build/WNDR3700
$(STAGING_DIR_HOST)/bin/wndr3700 \
$(KDIR)/vmlinux-$(2).uImage \
$(KDIR)/wndr3700/image/uImage
- $(MKSQUASHFS_CMD) \
+ $(STAGING_DIR_HOST)/bin/mksquashfs-lzma \
$(KDIR)/wndr3700 $(KDIR)/vmlinux-$(2).uImage.squashfs.tmp \
- -nopad -noappend -root-owned $(SQUASHFS_OPTS)
+ -nopad -noappend -root-owned -be
-rm -rf $(KDIR)/wndr3700
mkimage -A mips -O linux -T filesystem -C none \
-a 0xbf070000 -e 0xbf070000 \