aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2010-03-11 16:37:11 +0000
committerNicolas Thill <nico@openwrt.org>2010-03-11 16:37:11 +0000
commite522293953978999c7caa7962b90119f8ee2a9d7 (patch)
tree5d524c731822e0cc35fa7542a15dda4cc648377c
parent1586348a1af5a37a217dd45c7ce368f07fbda3eb (diff)
downloadupstream-e522293953978999c7caa7962b90119f8ee2a9d7.tar.gz
upstream-e522293953978999c7caa7962b90119f8ee2a9d7.tar.bz2
upstream-e522293953978999c7caa7962b90119f8ee2a9d7.zip
[package] kernel: fix kmod-pcmcia-yenta on 2.4
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20147 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/kernel/modules/other.mk15
1 files changed, 14 insertions, 1 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index d3f1df832c..6c7f42c759 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -170,7 +170,19 @@ define KernelPackage/pcmcia-yenta
SUBMENU:=$(OTHER_MENU)
TITLE:=yenta socket driver
DEPENDS:=kmod-pcmcia-core
- KCONFIG:=CONFIG_YENTA
+ KCONFIG:= \
+ CONFIG_PCMCIA \
+ CONFIG_CARDBUS \
+ CONFIG_YENTA
+endef
+
+define KernelPackage/pcmcia-yenta/2.4
+ FILES:= \
+ $(LINUX_DIR)/drivers/pcmcia/yenta_socket.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,41,yenta_socket)
+endef
+
+define KernelPackage/pcmcia-yenta/2.6
FILES:= \
$(LINUX_DIR)/drivers/pcmcia/rsrc_nonstatic.$(LINUX_KMOD_SUFFIX) \
$(LINUX_DIR)/drivers/pcmcia/yenta_socket.$(LINUX_KMOD_SUFFIX)
@@ -179,6 +191,7 @@ endef
$(eval $(call KernelPackage,pcmcia-yenta))
+
define KernelPackage/pcmcia-au1000
SUBMENU:=$(OTHER_MENU)
TITLE:=RMI/AMD Au1000 PCMCIA support